classification
Title: [Suggestion] Improve documentation for set() API
Type: enhancement Stage: resolved
Components: Documentation Versions: Python 3.6
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: rhettinger Nosy List: Jacob Pratt, docs@python, martin.panter, rhettinger
Priority: normal Keywords:

Created on 2017-06-03 04:05 by Jacob Pratt, last changed 2017-06-04 17:37 by rhettinger. This issue is now closed.

Messages (3)
msg295064 - (view) Author: Jacob Pratt (Jacob Pratt) Date: 2017-06-03 04:05
While going through the documentation, I found that set() has surprisingly little documentation, not even a list of built-in methods.

I'm not sure exactly what is missing, but I know that issubset and issuperset isn't in there (that's what I was looking for, specifically).

Thanks!
msg295069 - (view) Author: Martin Panter (martin.panter) * (Python committer) Date: 2017-06-03 07:04
Did you see <https://docs.python.org/3.6/library/stdtypes.html#set-types-set-frozenset>?
msg295112 - (view) Author: Raymond Hettinger (rhettinger) * (Python committer) Date: 2017-06-03 23:33
This looks like an invalid request.
History
Date User Action Args
2017-06-04 17:37:29rhettingersetstatus: open -> closed
resolution: not a bug
stage: resolved
2017-06-03 23:33:37rhettingersetassignee: docs@python -> rhettinger
messages: + msg295112
2017-06-03 19:08:02ned.deilysetstatus: pending -> open
nosy: + rhettinger
2017-06-03 07:04:30martin.pantersetstatus: open -> pending

nosy: + docs@python, martin.panter
messages: + msg295069

assignee: docs@python
components: + Documentation
2017-06-03 04:05:36Jacob Prattcreate