classification
Title: [EASY] SubinterpThreadingTests.test_threads_join_2() of test_threading leaks references
Type: resource usage Stage: resolved
Components: Versions: Python 3.7
process
Status: closed Resolution: duplicate
Dependencies: Superseder: [Windows] SubinterpreterTest.test_callbacks_leak() of test_atexit leaks references
View: 30547
Assigned To: Nosy List: eric.snow, haypo, sayanchowdhury, serhiy.storchaka, zach.ware
Priority: normal Keywords: easy (C)

Created on 2017-06-01 10:42 by haypo, last changed 2017-06-08 10:47 by serhiy.storchaka. This issue is now closed.

Messages (4)
msg294932 - (view) Author: STINNER Victor (haypo) * (Python committer) Date: 2017-06-01 10:42
Ah! I succeeded to hack a tool to bisect -m test -R 3:3 failure (issue #29512, I will publish it later, right now it's too hackish), so I found a first guilty of failure on the Gentoo Refleak failure.

Maybe it's related to recent Eric Snow's work. Maybe not. I didn't dig the bug yet.

haypo@selma$ ./python -m test -R 3:3 -m test_threads_join_2 test_threading
Run tests sequentially
0:00:00 load avg: 0.16 [1/1] test_threading
beginning 6 repetitions
123456
......
test_threading leaked [3, 3, 3] references, sum=9
test_threading failed

1 test failed:
    test_threading

Total duration: 2 sec
Tests result: FAILURE
msg294997 - (view) Author: STINNER Victor (haypo) * (Python committer) Date: 2017-06-02 09:07
I tagged this issue as easy. I consider that it's a good exercice for new contributors. Core developers: please let new contributors try to fix it since this issue is not critical, try to explain how to fix it rather than writing the fix ;-)
msg295024 - (view) Author: Sayan Chowdhury (sayanchowdhury) * Date: 2017-06-02 15:20
I replicated the issue. Starting to work on the issue.
msg295393 - (view) Author: STINNER Victor (haypo) * (Python committer) Date: 2017-06-08 10:20
This issue is a duplicate of bpo-30547.

I tested that bpo-30547 fixes this issue.
History
Date User Action Args
2017-06-08 10:47:04serhiy.storchakasetsuperseder: [Windows] SubinterpreterTest.test_callbacks_leak() of test_atexit leaks references
2017-06-08 10:20:50hayposetstatus: open -> closed
resolution: duplicate
messages: + msg295393

stage: resolved
2017-06-02 15:20:34sayanchowdhurysetnosy: + sayanchowdhury
messages: + msg295024
2017-06-02 09:07:56hayposetkeywords: + easy (C)

messages: + msg294997
title: SubinterpThreadingTests.test_threads_join_2() of test_threading leaks references -> [EASY] SubinterpThreadingTests.test_threads_join_2() of test_threading leaks references
2017-06-01 10:42:19haypocreate