classification
Title: asyncio.wrap_future() is not documented
Type: enhancement Stage: resolved
Components: asyncio, Documentation Versions: Python 3.7
process
Status: closed Resolution: duplicate
Dependencies: Superseder: asyncio.wrap_future undocumented
View: 24755
Assigned To: docs@python Nosy List: adisbladis, docs@python, vstinner, yselivanov
Priority: normal Keywords:

Created on 2017-03-10 15:15 by vstinner, last changed 2017-03-10 21:28 by martin.panter. This issue is now closed.

Pull Requests
URL Status Linked Edit
PR 603 adisbladis, 2017-03-10 19:45
Messages (2)
msg289376 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2017-03-10 15:15
The following asyncio function is not documented. Is it deliberate? The function is exported in the asyncio module.

def wrap_future(future, *, loop=None):
    """Wrap concurrent.futures.Future object."""
msg289403 - (view) Author: Adam Höse (adisbladis) * Date: 2017-03-10 19:45
While fixing this issue I found that it's a duplicate of issue 24755.
History
Date User Action Args
2017-03-10 21:28:41martin.pantersetstatus: open -> closed
superseder: asyncio.wrap_future undocumented
resolution: duplicate
stage: resolved
2017-03-10 19:45:40adisbladissetnosy: + adisbladis
messages: + msg289403
pull_requests: + pull_request498

type: enhancement
2017-03-10 15:53:46gvanrossumsetnosy: - gvanrossum
2017-03-10 15:15:39vstinnercreate