classification
Title: test_subprocess fails on Darwin
Type: behavior Stage:
Components: Tests Versions: Python 3.0
process
Status: closed Resolution: works for me
Dependencies: Superseder:
Assigned To: Nosy List: benjamin.peterson, donmez
Priority: normal Keywords:

Created on 2008-05-26 18:26 by donmez, last changed 2008-05-26 19:56 by benjamin.peterson. This issue is now closed.

Messages (3)
msg67381 - (view) Author: Ismail Donmez (donmez) * Date: 2008-05-26 18:26
./python -E -tt -bb ./Lib/test/regrtest.py -l  -uall
[...]
test_subprocess
.
    this bit of output is from a test of stdout in a different process 
...
test test_subprocess failed -- Traceback (most recent call last):
  File "/Users/cartman/Sources/py3k/Lib/test/test_subprocess.py", line 
407, in test_no_leaking
    data = p.communicate("lime")[0]
  File "/Users/cartman/Sources/py3k/Lib/subprocess.py", line 599, in 
communicate
    return self._communicate(input)
  File "/Users/cartman/Sources/py3k/Lib/subprocess.py", line 1086, in 
_communicate
    rlist, wlist, xlist = select.select(read_set, write_set, [])
select.error: (4, 'Interrupted system call')
msg67383 - (view) Author: Benjamin Peterson (benjamin.peterson) * (Python committer) Date: 2008-05-26 19:21
This works fine for me.
msg67386 - (view) Author: Ismail Donmez (donmez) * Date: 2008-05-26 19:56
On a second run, I can't reproduce this. There might be a race somewhere 
but until it can be reproduced this bug can be closed. Thanks for your 
attention.
History
Date User Action Args
2008-05-26 19:56:48benjamin.petersonsetstatus: open -> closed
resolution: works for me
2008-05-26 19:56:16donmezsetmessages: + msg67386
2008-05-26 19:21:58benjamin.petersonsetnosy: + benjamin.peterson
messages: + msg67383
2008-05-26 18:26:38donmezcreate