classification
Title: test_asyncio & test_multiprocessing_forkserver failed
Type: behavior Stage: resolved
Components: Build Versions: Python 3.6
process
Status: closed Resolution: works for me
Dependencies: Superseder:
Assigned To: Nosy List: Dima Zhukov, louielu, mawidjaj, xiang.zhang
Priority: normal Keywords:

Created on 2017-02-17 13:23 by Dima Zhukov, last changed 2017-02-22 06:26 by xiang.zhang. This issue is now closed.

Files
File name Uploaded Description Edit
tests.output Dima Zhukov, 2017-02-17 13:23
Messages (6)
msg288005 - (view) Author: Dima Zhukov (Dima Zhukov) Date: 2017-02-17 13:23
Hi, i'm new to Python. Just have downloded source code and tried to install it, but "make test" failed 2 test: test_asyncio  and test_multiprocessing_forkserver. How bad is it and what should i do? Logs attached
msg288188 - (view) Author: Xiang Zhang (xiang.zhang) * (Python committer) Date: 2017-02-20 08:50
Hi Dima, can you stably reproduce the failures? Or try with the latest 3.6 code?
msg288288 - (view) Author: Dima Zhukov (Dima Zhukov) Date: 2017-02-21 11:58
Just tried with 3.4.6 version. Same test failed
msg288335 - (view) Author: Marcel Widjaja (mawidjaj) * Date: 2017-02-22 05:51
Both test_asyncio & test_multiprocessing_forkserver work for me. I'm on the latest 3.6 and Mac OS 10.11.6
msg288338 - (view) Author: Louie Lu (louielu) * Date: 2017-02-22 06:21
Both test_asyncio & test_multiprocessing_forkserver passed on latest 3.6 and 4.8.3-1-ARCH.
msg288339 - (view) Author: Xiang Zhang (xiang.zhang) * (Python committer) Date: 2017-02-22 06:26
Hmm, it seems not Python's fault. I can't reproduce the failure either. So I am going to close this issue.
History
Date User Action Args
2017-02-22 06:26:07xiang.zhangsetstatus: open -> closed
resolution: works for me
messages: + msg288339

stage: test needed -> resolved
2017-02-22 06:21:39louielusetnosy: + louielu
messages: + msg288338
2017-02-22 05:51:02mawidjajsetnosy: + mawidjaj
messages: + msg288335
2017-02-21 11:58:49Dima Zhukovsetmessages: + msg288288
2017-02-20 08:50:16xiang.zhangsetnosy: + xiang.zhang

messages: + msg288188
stage: test needed
2017-02-17 13:23:20Dima Zhukovcreate