classification
Title: silly readline module problem
Type: Stage:
Components: Extension Modules Versions: Python 2.5
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: AndyNovo, bgolemon, gpolo
Priority: normal Keywords:

Created on 2008-05-23 13:39 by AndyNovo, last changed 2008-05-24 13:03 by gpolo. This issue is now closed.

Messages (3)
msg67236 - (view) Author: Andy Novocin (AndyNovo) Date: 2008-05-23 13:39
I installed python 2.5.2 on my SUSE 10.3 system which came with 2.4.4
and when you type 
import readline
it returns No module named readline.

When installing I just unzipped, ./configure, make, sudo make install.

Im brand new to Linux and Python (probably clearly).
msg67282 - (view) Author: Buck Golemon (bgolemon) Date: 2008-05-24 03:59
I'm not sure what your problem is, but comp.lang.python might be a
better place to ask. It's not clear that this is a bug yet.

http://groups.google.com/group/comp.lang.python/topics
msg67299 - (view) Author: Guilherme Polo (gpolo) * (Python committer) Date: 2008-05-24 13:03
You need to install the development package of readline in order to have
the readline module compiled. And this is not a bug.
History
Date User Action Args
2008-05-24 13:03:53gpolosetstatus: open -> closed
resolution: not a bug
messages: + msg67299
nosy: + gpolo
2008-05-24 03:59:52bgolemonsetnosy: + bgolemon
messages: + msg67282
2008-05-23 13:39:26AndyNovocreate