classification
Title: Invalid example in documentation for PyErr_Fetch
Type: Stage: resolved
Components: Documentation Versions: Python 3.5
process
Status: closed Resolution: fixed
Dependencies: Superseder:
Assigned To: docs@python Nosy List: docs@python, kb1000, serhiy.storchaka, xiang.zhang
Priority: normal Keywords:

Created on 2017-01-26 16:25 by kb1000, last changed 2017-04-15 11:35 by kb1000. This issue is now closed.

Messages (7)
msg286321 - (view) Author: Kaeptm Blaubaer (kb1000) * Date: 2017-01-26 16:25
In the example are the pointers to pointers to PyObject too many,
because then PyErr_Fetch and PyErr_Restore would get too many pointers to pointers.
msg286324 - (view) Author: Serhiy Storchaka (serhiy.storchaka) * (Python committer) Date: 2017-01-26 17:05
The example looks correct to me. Could you please add more information? What example looks correct to you?
msg286366 - (view) Author: Kaeptm Blaubaer (kb1000) * Date: 2017-01-27 15:20
I had an outdated version of the documentation.
msg286370 - (view) Author: Kaeptm Blaubaer (kb1000) * Date: 2017-01-27 15:42
I had no outdated documentation, but the documentation of 3.5.
msg286863 - (view) Author: Xiang Zhang (xiang.zhang) * (Python committer) Date: 2017-02-03 13:09
I can't see any problem with the example either. So I just close this issue for now. But if you still think it gets problems please reopen it and tell your thoughts.
msg291711 - (view) Author: Kaeptm Blaubaer (kb1000) * Date: 2017-04-15 11:02
Please don't close the bug until it is fixed in the python 3.5 documentation!
msg291712 - (view) Author: Kaeptm Blaubaer (kb1000) * Date: 2017-04-15 11:35
The error is fixed in Python 3.5.3 documentation.
History
Date User Action Args
2017-04-15 11:35:47kb1000setstatus: open -> closed
resolution: fixed
messages: + msg291712
2017-04-15 11:02:27kb1000setstatus: closed -> open
resolution: not a bug -> (no value)
messages: + msg291711
2017-02-03 13:09:51xiang.zhangsetstatus: open -> closed

nosy: + xiang.zhang
messages: + msg286863

resolution: not a bug
stage: resolved
2017-01-27 15:42:11kb1000setstatus: closed -> open
resolution: out of date -> (no value)
messages: + msg286370

versions: + Python 3.5
2017-01-27 15:20:33kb1000setstatus: open -> closed
resolution: out of date
messages: + msg286366
2017-01-26 17:05:56serhiy.storchakasetnosy: + serhiy.storchaka
messages: + msg286324
2017-01-26 16:25:04kb1000create