classification
Title: TypeError by typing for Ellipsis
Type: behavior Stage:
Components: Versions: Python 3.6
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: Ádám Szieberth
Priority: normal Keywords:

Created on 2017-01-24 04:52 by Ádám Szieberth, last changed 2017-01-26 03:08 by Ádám Szieberth. This issue is now closed.

Messages (2)
msg286134 - (view) Author: Ádám Szieberth (Ádám Szieberth) Date: 2017-01-24 04:52
I would expect Ellipsis the same behavior as None in type hints instead of:

TypeError: Union[arg, ...]: each arg must be a type. Got Ellipsis.

... would be much nicer than type(...) there.
msg286292 - (view) Author: Ádám Szieberth (Ádám Szieberth) Date: 2017-01-26 03:08
Well, now I believe the way I suggested would conflict with other uses of Ellipsis in type hints.
History
Date User Action Args
2017-01-26 03:08:34Ádám Szieberthsetstatus: open -> closed
resolution: not a bug
messages: + msg286292
2017-01-24 04:52:52Ádám Szieberthcreate