classification
Title: Quiet Install
Type: behavior Stage: resolved
Components: Windows Versions: Python 3.6, Python 3.5
process
Status: closed Resolution: out of date
Dependencies: Superseder: Windows All Users installation places uninstaller in user profile
View: 25166
Assigned To: Nosy List: earl.maier, iritkatriel, paul.moore, steve.dower, tim.golden, zach.ware
Priority: normal Keywords:

Created on 2017-01-10 21:29 by earl.maier, last changed 2021-09-06 19:00 by steve.dower. This issue is now closed.

Files
File name Uploaded Description Edit
Capture.PNG earl.maier, 2017-01-10 21:29
Messages (6)
msg285159 - (view) Author: Earl Maier (earl.maier) Date: 2017-01-10 21:29
On quiet and passive Installs of Python 3.6 and 3.5 in windows 7 and 10 (x64), Python successfully installs but does not appear in programs and features. It would also appear that the append path and python launcher switches do not work for quiet install.  If installed manual everything functions as it should.

Quiet installs work just fine with version 2.7 (msi vs exe).

The installers used are the Windows x86-64 executable installer for both python 3.6.0 and 3.5.2.
msg287025 - (view) Author: Steve Dower (steve.dower) * (Python committer) Date: 2017-02-05 00:14
I think there's something else going on with your install, as I do these frequently and they work fine (modulo issue25166).

Can you grab all your log files from your %TEMP% directory and attach them here? I'm keen to see what the installer is trying to do vs. what's actually happening.
msg287169 - (view) Author: Earl Maier (earl.maier) Date: 2017-02-06 20:17
I have since rebuilt the machine that I was doing my testing on, so I am unable grab log files from the installs.  I have not been able to reproduce the issue since the rebuild of the machine.  On a good note: Everything is working as it should. I appreciate you looking into the issue.  

Thank you
msg287258 - (view) Author: Earl Maier (earl.maier) Date: 2017-02-07 22:07
Update. 

I have been able to reproduce the issue/pin point the problem.  The all user flag on the installer doesn't install under all users. I install as an admin (under a different user) but python doesn't install for the current user (user).
msg401165 - (view) Author: Irit Katriel (iritkatriel) * (Python committer) Date: 2021-09-06 17:26
Earl, is there still an open problem to look into here or can this be closed?
msg401175 - (view) Author: Steve Dower (steve.dower) * (Python committer) Date: 2021-09-06 19:00
The underlying issue is known and tracked by issue25166
History
Date User Action Args
2021-09-06 19:00:09steve.dowersetstatus: open -> closed
superseder: Windows All Users installation places uninstaller in user profile
messages: + msg401175

resolution: out of date
stage: resolved
2021-09-06 17:26:57iritkatrielsetnosy: + iritkatriel
messages: + msg401165
2017-02-07 22:07:26earl.maiersetmessages: + msg287258
2017-02-06 20:17:20earl.maiersetmessages: + msg287169
2017-02-05 00:14:10steve.dowersetmessages: + msg287025
2017-01-10 21:29:12earl.maiercreate