classification
Title: "No windows home dir" doc error
Type: behavior Stage: resolved
Components: Documentation Versions: Python 2.5
process
Status: closed Resolution: works for me
Dependencies: Superseder:
Assigned To: georg.brandl Nosy List: georg.brandl, loewis, python@johnburnett.com, r.david.murray
Priority: normal Keywords:

Created on 2008-05-19 21:29 by python@johnburnett.com, last changed 2009-06-07 15:16 by r.david.murray. This issue is now closed.

Messages (3)
msg67079 - (view) Author: John Burnett (python@johnburnett.com) Date: 2008-05-19 21:29
http://docs.python.org/inst/alt-install-windows.html

The above says "Windows has no concept of a user's home directory, and
since the standard Python installation under Windows is simpler than
under Unix, the --prefix option has traditionally been used to install
additional packages in separate locations on Windows."

However, any modern Windows OS does have that concept (i.e. see the
%USERPROFILE% env variable).  Not sure how to best change the above, but...
msg67106 - (view) Author: Martin v. Löwis (loewis) * (Python committer) Date: 2008-05-20 06:20
The problem is that any modern Windows does not just have a single home
directory for a user, but many of them. For example, there are the
HOMEDRIVE, HOMESHARE, and HOMEPATH variables, which may or may not be set.

In the light of these, I would argue that USERPROFILE is *not* the
user's "home" directory - it is the user's "profile" directory.

So I think that the text is practically correct as it stands.
msg89042 - (view) Author: R. David Murray (r.david.murray) * (Python committer) Date: 2009-06-07 15:16
Closing as 'works for me' since the OP hasn't responded with any counter
argument to Martin's assertion and it's been open for more than a year.
History
Date User Action Args
2009-06-07 15:16:59r.david.murraysetstatus: open -> closed
priority: normal


nosy: + r.david.murray
messages: + msg89042
resolution: works for me
stage: resolved
2008-05-20 06:20:53loewissetnosy: + loewis
messages: + msg67106
2008-05-19 22:07:33python@johnburnett.comsettype: behavior
2008-05-19 21:29:58python@johnburnett.comcreate