classification
Title: registry value to be cleared when python is uninstalled
Type: behavior Stage: resolved
Components: Windows Versions: Python 3.5
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: jha.amit6666, paul.moore, steve.dower, tim.golden, zach.ware
Priority: normal Keywords:

Created on 2017-01-04 04:48 by jha.amit6666, last changed 2017-02-05 00:15 by steve.dower. This issue is now closed.

Files
File name Uploaded Description Edit
1.png jha.amit6666, 2017-01-04 05:47
Messages (5)
msg284608 - (view) Author: (jha.amit6666) Date: 2017-01-04 04:48
I have installed python 3.5 on Windows and then uninstalled it. THe registry value HKEY_LOCAL_MACHINE\SOFTWARE\Python\PythonCore\3.5 is still present.

This is solved in python 3.6. So the work to be done here is: if there was any previous version of python installed and not present now, then the registry values should be cleared.

The behaviour of uninstallation of Python 3.6 is that the registry value is cleared.
msg284612 - (view) Author: (jha.amit6666) Date: 2017-01-04 05:47
The start menu shortcuts and the files in installation path "C:\Program Files\Python35" are also present. The thing should go when python3.5 is uninstalled.

This can be solved when newer version of python, i.e., python 3.6 is installed/uninstalled. During this time, a prompt should be shown.
msg284615 - (view) Author: Steve Dower (steve.dower) * (Python committer) Date: 2017-01-04 06:06
Interesting. I don't suppose you could find all the log files in your %TEMP% directory, put them in a zip file and attach them here? There may be some clue as to why this happened - it's certainly meant to clean everything up when you uninstall (except for site-packages, but definitely shortcuts and registry entries).
msg284712 - (view) Author: (jha.amit6666) Date: 2017-01-05 07:14
Before I read your comment, I ran disk clean up which deleted everything.
msg287026 - (view) Author: Steve Dower (steve.dower) * (Python committer) Date: 2017-02-05 00:15
Without logs showing what went wrong, there's nothing we can fix.
History
Date User Action Args
2017-02-05 00:15:18steve.dowersetstatus: open -> closed
resolution: not a bug
messages: + msg287026

stage: resolved
2017-01-05 07:14:28jha.amit6666setmessages: + msg284712
2017-01-04 06:06:44steve.dowersetmessages: + msg284615
2017-01-04 05:47:54jha.amit6666setfiles: + 1.png

messages: + msg284612
2017-01-04 04:48:12jha.amit6666create