classification
Title: Inconsistent use of underscore in names that start with "is"
Type: Stage: resolved
Components: Versions: Python 3.6
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: Kodiologist, r.david.murray
Priority: normal Keywords:

Created on 2016-12-27 20:22 by Kodiologist, last changed 2016-12-27 20:34 by r.david.murray. This issue is now closed.

Messages (2)
msg284133 - (view) Author: (Kodiologist) * Date: 2016-12-27 20:22
Compare ``isinstance``, ``issubclass``, and ``islower`` to ``is_integer``, ``is_fifo``, and ``is_enabled``. In Python 3.6, of all the names in the standard library starting with ``is``, I count 69 names with the underscore and 91 without. It seems better to pick one way or the other and stick with it. I would recommend using the underscore, for legibility.
msg284134 - (view) Author: R. David Murray (r.david.murray) * (Python committer) Date: 2016-12-27 20:34
Yep, that would be nice.  But Python has evolved over time, and we must maintain backward compatibility.  The names are what they are.
History
Date User Action Args
2016-12-27 20:34:42r.david.murraysetstatus: open -> closed

nosy: + r.david.murray
messages: + msg284134

resolution: not a bug
stage: resolved
2016-12-27 20:22:35Kodiologistcreate