classification
Title: Docs should say set.update takes iterable
Type: Stage:
Components: Documentation Versions: Python 3.5
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: docs@python Nosy List: docs@python, nre3976, r.david.murray
Priority: normal Keywords:

Created on 2016-12-16 09:13 by nre3976, last changed 2016-12-16 21:13 by rhettinger. This issue is now closed.

Messages (2)
msg283394 - (view) Author: Nick Evans (nre3976) Date: 2016-12-16 09:13
The docs say that set.update takes *args:

  update(*others)

But actually set.update takes an optional iterable:

  update([iterable])
msg283399 - (view) Author: R. David Murray (r.david.murray) * (Python committer) Date: 2016-12-16 14:06
update([iterable]) is a specific case of update(*others).  udpate([1, 2], [3, 4]) is another specific case.
History
Date User Action Args
2016-12-16 21:13:32rhettingersetstatus: open -> closed
resolution: not a bug
2016-12-16 14:06:01r.david.murraysetnosy: + r.david.murray
messages: + msg283399
2016-12-16 09:13:52nre3976create