classification
Title: 3.6.0rc1 installer fails to install / uninstall.
Type: behavior Stage: resolved
Components: Installation, Windows Versions: Python 3.6
process
Status: closed Resolution: out of date
Dependencies: Superseder:
Assigned To: Nosy List: Decorater, paul.moore, steve.dower, tim.golden, zach.ware
Priority: normal Keywords:

Created on 2016-12-08 06:24 by Decorater, last changed 2016-12-28 23:47 by steve.dower. This issue is now closed.

Files
File name Uploaded Description Edit
Python 3.6.0rc1 (64-bit)_20161210164706.log Decorater, 2016-12-10 22:59
Messages (7)
msg282694 - (view) Author: Decorater (Decorater) * Date: 2016-12-08 06:24
When installing python 3.6.0rc1 it errors saying that it cannot find python.dll  in cab1.cab (or some sort of file name similar to that) which it would obviously not exist. and then when I try to uninstall it it will fail saying 3.6 is not installed but not check the registry to remove the entries for the windows Installed programs list.

I would like if the (web and non web) installers would actually get better and check right before closing if 3.6 is in the registry when it cant find one installed and remove those entries. As well as looking for previous python versions that lo longer are on disk but are on the registry as if they are installed (basically allows for proper cleanup).
msg282706 - (view) Author: Steve Dower (steve.dower) * (Python committer) Date: 2016-12-08 14:08
If you run the installer through the Programs and Features dialog to modify or uninstall it should definitely find the current installation (as the registration it looks for is the same registration that makes it appear in that dialog). Because there are different installers, unfortunately they can't always detect each other despite laying down the same version of Python. I too would like them to get better at this, but it's not at all simple.

We can't go wiping install information arbitrarily or it will corrupt user machines.

For the missing file error, you should have a whole lot of log files in your %TEMP% directory. Could you zip them up and attach them here so I can take a look at what went wrong?
msg282759 - (view) Author: Decorater (Decorater) * Date: 2016-12-09 04:52
Ah I know what the problem is now. It is the fact that the 32 Bit Webinstaller does not check to see if a 64 bit version is installed at the folder that the 32 bit version is set to to uninstall the 64 bit version 1st thereby it overwrites the data to the 36 bit install without removing the registry entries for the 64 bit install. Thereby why I cant uninstall, repair, or even reinstall the 64 bit version.
msg282765 - (view) Author: Steve Dower (steve.dower) * (Python committer) Date: 2016-12-09 06:08
Ah, did you change the default install directory to be the same as your previous install? Yeah, that's bad :) There's other registration information that we look at, so we don't even try and look at the existing files.

However, if you didn't change the directory, then that's a really bad bug on our side. But I think we'd be hearing many more issues if that was the problem.
msg282884 - (view) Author: Decorater (Decorater) * Date: 2016-12-10 22:52
Well, not only that but now when I try to uninstall the 64 bit version it seems to not be able to find when on the "Add to path" part of Uninstaller
E:\ProgramData\Package Cache\{815FC13F-79DD-484C-8788-028D69569000}v3.6.121.0\
and some other folders.

I think What the webinstaller should do when it cant find the file/files is to download them again and then run the uninstall in case otherwise there is no other way to actually uninstall it.
msg282886 - (view) Author: Decorater (Decorater) * Date: 2016-12-10 23:22
I found the registry keys for all python version Except for the keys that Adds it to path to manually uninstall the Add to Path. Other than that Everything Else has been found and take cared of manually thanks to Windows built in Registry Editor.
msg284214 - (view) Author: Steve Dower (steve.dower) * (Python committer) Date: 2016-12-28 23:47
I believe this is out of date now, but if you have similar issues with the final release, feel free to respond to this thread again.
History
Date User Action Args
2016-12-28 23:47:13steve.dowersetstatus: open -> closed
resolution: out of date
messages: + msg284214

stage: resolved
2016-12-10 23:22:07Decoratersetmessages: + msg282886
2016-12-10 22:59:47Decoratersetfiles: + Python 3.6.0rc1 (64-bit)_20161210164706.log
2016-12-10 22:56:51Decoratersetfiles: - Python 3.6.0rc1 (64-bit)_20161210164706.log
2016-12-10 22:56:11Decoratersetfiles: + Python 3.6.0rc1 (64-bit)_20161210164706.log
2016-12-10 22:52:36Decoratersetmessages: + msg282884
2016-12-09 06:08:05steve.dowersetmessages: + msg282765
2016-12-09 04:52:21Decoratersetmessages: + msg282759
2016-12-08 14:08:24steve.dowersetmessages: + msg282706
2016-12-08 06:35:33Decoratersettype: behavior
2016-12-08 06:24:41Decoratercreate