classification
Title: abc module fails to reject instantiation of some multiply-inheriting classes that fail to implement abstract methods
Type: behavior Stage: resolved
Components: Library (Lib) Versions: Python 3.7, Python 3.6, Python 3.3, Python 3.4, Python 3.5, Python 2.7
process
Status: closed Resolution: duplicate
Dependencies: Superseder: abstract class instantiable when subclassing built-in types
View: 5996
Assigned To: Nosy List: Nathaniel Manista, aleax, cvrebert, r.david.murray
Priority: normal Keywords:

Created on 2016-10-25 23:42 by Nathaniel Manista, last changed 2016-10-26 00:44 by r.david.murray. This issue is now closed.

Files
File name Uploaded Description Edit
abc_what.py Nathaniel Manista, 2016-10-25 23:42
Messages (2)
msg279465 - (view) Author: Nathaniel Manista (Nathaniel Manista) Date: 2016-10-25 23:42
The attached file when executed should fail (raise an exception) one line above where it actually does. Right?

I discovered this in 2.7 but have confirmed that it's still a problem in 3.6.0b2.
msg279473 - (view) Author: R. David Murray (r.david.murray) * (Python committer) Date: 2016-10-26 00:44
Thanks for the report, but this is a duplicate of issue 5996.
History
Date User Action Args
2016-10-26 00:44:33r.david.murraysetstatus: open -> closed

superseder: abstract class instantiable when subclassing built-in types

nosy: + r.david.murray
messages: + msg279473
resolution: duplicate
stage: resolved
2016-10-25 23:55:32cvrebertsetnosy: + cvrebert
2016-10-25 23:42:42Nathaniel Manistacreate