classification
Title: Windows: "Runtime Error!" crash from pythonw.exe (3.0a5)
Type: crash Stage:
Components: Versions: Python 3.0
process
Status: closed Resolution: out of date
Dependencies: Superseder:
Assigned To: Nosy List: amaury.forgeotdarc, terry.reedy
Priority: normal Keywords:

Created on 2008-05-12 20:55 by terry.reedy, last changed 2008-08-10 18:04 by terry.reedy. This issue is now closed.

Messages (5)
msg66757 - (view) Author: Terry J. Reedy (terry.reedy) * (Python committer) Date: 2008-05-12 20:55
Specific instance: I edit a file with IDLE, hit F5, and Windows pops up
a box with a white X in a red circle followed by "Runtime Error!" and an
explanation that the application requested to be closed in an 'unusual'
way.  

Clicking OK on that bring up a similar box. For the current incident,
this has title "t1.py - C:\Program Files\Python30\misc\t1.py:
pythonw.exe - Application Error" and contents "The exception unknown
software exception (0x40000015) occurred in the application at location
0x00d88cef.  Click on OK to terminate the program"

This has happened about three times in the last week since installing
a5. I am not sure if it happened before but it is only occasional (1 in
20 runs?) and I did not use a4 much.  It is possible that this only
happens after sleep or hibernation -- I will watch more carefully.  I
only run pythonw as a side-effect of running IDLE, so I do not know if
that is necessary or not.

As previously, when I reopened IDLE and the the file and ran it
unchanged, I got the appropriate output in the Shell window, as if
nothing were ever amiss.
msg66770 - (view) Author: Terry J. Reedy (terry.reedy) * (Python committer) Date: 2008-05-13 05:34
Hibernation, sleep, or screen saver is not required though process may
have been swapped to disk.  Exception and location are reproducible. 
This time I get IDLE Subprocess Startup Error on retry.  Will reboot.
msg66773 - (view) Author: Terry J. Reedy (terry.reedy) * (Python committer) Date: 2008-05-13 06:51
AFter reboot, IDLE started, loaded the program I tried to run
previously, and ran it several times.  I closed the edit window and when
I closed the shell window, got same message.  The first box is titled
Microsoft Visual C++ Runtime Library.  After listing ...pythonw.exe, it says

"This program has asked the Runtime to terminate it in an unusual way.
Please contact the application's support team for more information."

This time there is no second red-circle-X box but a Send Error Report to
Microsoft box.  That leads to Error Signature
AppName: pythonw.exe	 AppVer: 0.0.0.0	 ModName: tcl84.dll
ModVer: 8.4.2.16	 Offset: 00058cef

More testing: If I open the shell and do stuff interactively and close,
it closes ok as far as I have tested.  If I open the shell and an edit
window and close both, either order, even without running anything, then
it crashes on the second close.  I tried more than one file with the
same result.
msg66774 - (view) Author: Amaury Forgeot d'Arc (amaury.forgeotdarc) * (Python committer) Date: 2008-05-13 08:19
The 0x40000015 code and the message you get are typical of a call to
abort().

Ideed, I can reproduce the problem on windows 2000:
- start IDLE
- menu "File / New Window"
- close both windows

When running with python_d.exe, I see the message:
    Tk_Get3DBorderFromObj called with non-existent border!
which appears in a call to a panic() function in 
    tk8.4.16/generic/tk3d.c
msg70988 - (view) Author: Terry J. Reedy (terry.reedy) * (Python committer) Date: 2008-08-10 18:04
I am closing this as 'out of date' because the problem went away in .b1
and is still gone in .b2.  There is still, however, a crash problem if a
file is run with utf-8.  See http://bugs.python.org/issue2827
History
Date User Action Args
2008-08-10 18:04:01terry.reedysetstatus: open -> closed
resolution: out of date
messages: + msg70988
2008-05-13 08:20:04amaury.forgeotdarcsetnosy: + amaury.forgeotdarc
messages: + msg66774
2008-05-13 06:51:56terry.reedysetmessages: + msg66773
2008-05-13 05:34:25terry.reedysetmessages: + msg66770
2008-05-12 20:58:38terry.reedysettype: crash
2008-05-12 20:55:23terry.reedycreate