classification
Title: Fix test_cProfile
Type: Stage:
Components: Versions: Python 3.1, Python 3.2, Python 2.7
process
Status: closed Resolution: out of date
Dependencies: Superseder:
Assigned To: Nosy List: BreamoreBoy, alexandre.vassalotti, barry, benjamin.peterson, brett.cannon, mark.dickinson
Priority: normal Keywords:

Created on 2008-05-02 23:15 by benjamin.peterson, last changed 2012-11-17 17:06 by brett.cannon. This issue is now closed.

Messages (14)
msg66131 - (view) Author: Benjamin Peterson (benjamin.peterson) * (Python committer) Date: 2008-05-02 23:15
test_cProfile has been disabled in Py3k for a while now. It should be
fixed before release.
msg66168 - (view) Author: Brett Cannon (brett.cannon) * (Python committer) Date: 2008-05-03 20:01
A key thing to realize is that test_cprofile has heavily changed in
2.6 compared to what is currently disabled in 3.0.
msg68016 - (view) Author: Alexandre Vassalotti (alexandre.vassalotti) * (Python committer) Date: 2008-06-11 20:50
I will try to fix this one with profile/cProfile merge.
msg70481 - (view) Author: Benjamin Peterson (benjamin.peterson) * (Python committer) Date: 2008-07-31 02:15
Alexandre, are you still computerless?
msg70667 - (view) Author: Alexandre Vassalotti (alexandre.vassalotti) * (Python committer) Date: 2008-08-03 22:42
Not anymore! :-)
msg72417 - (view) Author: Brett Cannon (brett.cannon) * (Python committer) Date: 2008-09-03 21:19
So is this going to be a 3.1 issue or a 3.0 one? If it's the former then
it should not be a release blocker. But if is going to be for 3.0 then
the version list is wrong.
msg72470 - (view) Author: Barry A. Warsaw (barry) * (Python committer) Date: 2008-09-04 02:49
I guess since this hasn't been done by now, it's not going to get done
for 3.0, so I'm lowering the priority on it.
msg74391 - (view) Author: Benjamin Peterson (benjamin.peterson) * (Python committer) Date: 2008-10-06 21:21
Done in r66817.
msg74395 - (view) Author: Alexandre Vassalotti (alexandre.vassalotti) * (Python committer) Date: 2008-10-06 22:06
Have you verified the numbers? They don't look right to me.

The problem is the 2nd argument of cProfile's constructor has a
different semantic meaning than the one for profile.py. For profile.py,
it is used to set the "bias" (I presume it means the overhead) of the
profiler. But for cProfile, it's the unit (in seconds?) of timer used.

Personally, I have no idea which semantic should be preferred. So
perhaps, the best thing to do for now is remove the second argument from
the cls.profilerclass() call in test_profile.ProfileTest:

class ProfileTest:
    ...
    def do_profiling(cls):
        ...
        prof = cls.profilerclass(timer, 0.001)
        ...
msg74396 - (view) Author: Benjamin Peterson (benjamin.peterson) * (Python committer) Date: 2008-10-06 22:08
No, I didn't look too hard at it; I just got it scraping along, so I can
forward port a fix for it. I'll reopen this, so you can take more
action, so you wish. :)
msg74397 - (view) Author: Alexandre Vassalotti (alexandre.vassalotti) * (Python committer) Date: 2008-10-06 22:10
Unassigning myself as I don't have the time to fix this properly.
msg109475 - (view) Author: Mark Lawrence (BreamoreBoy) * Date: 2010-07-07 14:01
Is there anybody who can run with this as it's been in limbo for over two years?
msg111996 - (view) Author: Mark Lawrence (BreamoreBoy) * Date: 2010-07-29 20:34
Nobody has responded to msg109475 so I'll close unless there are any objections.
msg111999 - (view) Author: Mark Dickinson (mark.dickinson) * (Python committer) Date: 2010-07-29 20:39
> I'll close unless there are any objections.

Yes, I object! :)

If there's still a bug present, it seems inappropriate to close this issue.  So as a first step, someone needs to look at this closely to determine whether there *is* still a problem that needs fixing.  (It's not clear to me at the moment whether that's true.)
History
Date User Action Args
2012-11-17 17:06:14brett.cannonsetstatus: open -> closed
resolution: out of date
2010-07-29 20:39:28mark.dickinsonsetstatus: pending -> open
nosy: + mark.dickinson
messages: + msg111999

2010-07-29 20:34:22BreamoreBoysetstatus: open -> pending
priority: high -> normal
messages: + msg111996
2010-07-07 14:01:23BreamoreBoysetnosy: + BreamoreBoy

messages: + msg109475
versions: + Python 2.7, Python 3.2
2008-11-06 03:18:27benjamin.petersonsetpriority: critical -> high
2008-10-06 22:10:39alexandre.vassalottisetassignee: alexandre.vassalotti ->
2008-10-06 22:10:31alexandre.vassalottisetmessages: + msg74397
2008-10-06 22:08:30benjamin.petersonsetstatus: closed -> open
resolution: fixed -> (no value)
messages: + msg74396
2008-10-06 22:06:07alexandre.vassalottisetmessages: + msg74395
2008-10-06 21:21:07benjamin.petersonsetstatus: open -> closed
resolution: fixed
messages: + msg74391
2008-09-04 02:49:44barrysetpriority: release blocker -> critical
nosy: + barry
messages: + msg72470
2008-09-03 21:19:30brett.cannonsetmessages: + msg72417
2008-08-24 19:01:06nnorwitzsetpriority: critical -> release blocker
2008-08-21 14:27:29benjamin.petersonsetversions: + Python 3.1, - Python 3.0
2008-08-03 22:42:37alexandre.vassalottisetmessages: + msg70667
2008-07-31 02:15:34benjamin.petersonsetmessages: + msg70481
2008-06-11 20:50:47alexandre.vassalottisetassignee: alexandre.vassalotti
messages: + msg68016
nosy: + alexandre.vassalotti
2008-05-03 20:01:51brett.cannonsetnosy: + brett.cannon
messages: + msg66168
2008-05-02 23:15:09benjamin.petersoncreate