classification
Title: SIGSEV in test_window_funcs of test_curses
Type: crash Stage: resolved
Components: Library (Lib) Versions: Python 3.6
process
Status: closed Resolution: out of date
Dependencies: Superseder:
Assigned To: Nosy List: serhiy.storchaka, twouters, xdegaye
Priority: normal Keywords:

Created on 2016-06-15 10:26 by xdegaye, last changed 2019-04-14 19:40 by xdegaye. This issue is now closed.

Files
File name Uploaded Description Edit
gdb.log xdegaye, 2016-06-15 10:26
Messages (2)
msg268617 - (view) Author: Xavier de Gaye (xdegaye) * (Python triager) Date: 2016-06-15 10:26
This is with ncurses 6.0.

When running the test suite with:

./python -bb -E -Wd -m test -r -w -uall

test_curses fails as reported in issue 27323 and when the test runner re-runs test_curses in verbose mode at the end to test for a transient error, it happens sometimes that test_curses crashes. See the gdb backtrace attached.
msg340229 - (view) Author: Xavier de Gaye (xdegaye) * (Python triager) Date: 2019-04-14 19:40
Cannot reproduce the crash with Python 3.7.3 on ncurses 6.1.
History
Date User Action Args
2019-04-14 19:40:05xdegayesetstatus: open -> closed
resolution: out of date
messages: + msg340229

stage: resolved
2016-06-15 10:26:36xdegayecreate