classification
Title: SIGSEGV when calling os.forkpty()
Type: crash Stage: resolved
Components: Versions: Python 3.4, Python 2.7
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: Alexander Haensch, ned.deily
Priority: normal Keywords:

Created on 2016-06-10 12:27 by Alexander Haensch, last changed 2016-06-19 20:21 by ned.deily. This issue is now closed.

Messages (2)
msg268118 - (view) Author: Alexander Haensch (Alexander Haensch) Date: 2016-06-10 12:27
I recieve a segmentation fault if i call os.forkpty(). It does not happen with os.openpty(). Moreover os.fork() works fine.

The basesystem is gentoo-hardened. It does only happens if threading is enabled, which is the standard.

Tested python versions: 2.7.10, 3.4.3 
Some backtraces and py-bt are found here:

https://bugs.gentoo.org/show_bug.cgi?id=584916

Is this a known issue? At the moment i am thinking that gcc is "optimizing" something here.
msg268867 - (view) Author: Ned Deily (ned.deily) * (Python committer) Date: 2016-06-19 20:21
From a quick search of the issue tracker, I didn't find any previous reports of this.  We do have a couple of gentoo buildbots but probably not gentoo-hardened.  So I don't think this issue is going to go anywhere here and I'm going to close it.  If anyone does find evidence of a problem in Python, please reopen.  Good luck!
History
Date User Action Args
2016-06-19 20:21:19ned.deilysetstatus: open -> closed

nosy: + ned.deily
messages: + msg268867

resolution: not a bug
stage: resolved
2016-06-10 12:27:10Alexander Haenschcreate