classification
Title: Kafka Python Consumer Messages gets truncated
Type: performance Stage: resolved
Components: Library (Lib) Versions: Python 2.7
process
Status: closed Resolution: third party
Dependencies: Superseder:
Assigned To: Nosy List: ned.deily, rgowda@threatmetrix.com
Priority: normal Keywords:

Created on 2016-06-06 00:06 by rgowda@threatmetrix.com, last changed 2016-06-06 00:12 by ned.deily. This issue is now closed.

Messages (2)
msg267487 - (view) Author: Rahul (rgowda@threatmetrix.com) Date: 2016-06-06 00:06
Snippet code is below:
from kafka import KafkaConsumer
from kafka.client import KafkaClient
from kafka.consumer import SimpleConsumer

consumer = KafkaConsumer('eventdetails_ingestion' , group_id='1',bootstrap_servers=‘xxxx:9092', max_partition_fetch_bytes=10555555)
for msg in consumer:
    try:
        jValue = json.loads(str(msg.value))
   except ValueError:
        fileErr.write(str(msg.value)+"\n")

Steps:
We send/produce large sets of messages to Kafka of around 20 to 30 KB size each messages in JSON format and producing around 200 messages / sec for 1 hour duration. We have 3 Kafka Brokers running and I am trying to consume the messages from these 3 Kafka Brokers from the same topic using the above code. The problem is that sometimes some of the messages gets truncated, I am not sure why it happen ?
msg267490 - (view) Author: Ned Deily (ned.deily) * (Python committer) Date: 2016-06-06 00:12
Sorry, kafka is a third-party package, not part of the Python Standard Library.  Suggest you pursue this with the Kafka project:

http://kafka-python.readthedocs.io/en/master/support.html
History
Date User Action Args
2016-06-06 00:12:30ned.deilysetstatus: open -> closed

nosy: + ned.deily
messages: + msg267490

resolution: third party
stage: resolved
2016-06-06 00:06:03rgowda@threatmetrix.comcreate