classification
Title: Python IDLE doesn't like 💙
Type: Stage: resolved
Components: IDLE Versions: Python 3.5
process
Status: closed Resolution: duplicate
Dependencies: Superseder: IDLE 3.x on Windows crashes when pasting non-BMP unicode
View: 13153
Assigned To: Nosy List: Christian.Kleineidam, martin.panter, vstinner
Priority: normal Keywords:

Created on 2016-05-23 12:40 by Christian.Kleineidam, last changed 2016-05-24 08:55 by eryksun. This issue is now closed.

Messages (4)
msg266138 - (view) Author: Christian Kleineidam (Christian.Kleineidam) Date: 2016-05-23 12:40
When I past 💙 into the Python IDLE it closes automatically. 
I would be fine with the IDLE not being able to display the character. Automatically closing seems however excessive.
msg266140 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2016-05-23 12:43
What is your OS? Windows?

What is the full Python version (see the IDLE window title)?

Note: I cannot reproduce the issue on Linux with Python 3.4.3: pasting a string which contains 💙 do nothing, whereas pasting pure ASCII string works well.

I recall the TCL doesn't have a full support of Unicode, usually it only supports BMP (U+0000-U+ffff).

💙 is a non-BMP character: U+1f499.
msg266145 - (view) Author: Martin Panter (martin.panter) * (Python committer) Date: 2016-05-23 13:19
Is this the same as Issue 13153?
msg266238 - (view) Author: Christian Kleineidam (Christian.Kleineidam) Date: 2016-05-24 08:23
My version is: Python 3.5.0 (v3.5.0:374f501f4567, Sep 13 2015, 02:16:59) [MSC v.1900 32 bit (Intel)] on win32

Yes, I think the issue is likely a dublicate of http://bugs.python.org/issue13153
History
Date User Action Args
2016-05-24 08:55:05eryksunsetstatus: open -> closed
superseder: IDLE 3.x on Windows crashes when pasting non-BMP unicode
resolution: duplicate
stage: resolved
2016-05-24 08:23:23Christian.Kleineidamsetmessages: + msg266238
2016-05-23 13:19:39martin.pantersetnosy: + martin.panter
messages: + msg266145
2016-05-23 12:43:59vstinnersetnosy: + vstinner
messages: + msg266140
2016-05-23 12:40:03Christian.Kleineidamcreate