classification
Title: os.path.realpath.__name__ is 'abspath'
Type: behavior Stage:
Components: Versions: Python 3.4, Python 2.7
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: Jon Morris, berker.peksag, ppperry
Priority: normal Keywords:

Created on 2016-05-04 11:56 by Jon Morris, last changed 2016-05-04 17:05 by brett.cannon. This issue is now closed.

Messages (3)
msg264804 - (view) Author: Jon Morris (Jon Morris) Date: 2016-05-04 11:56
A minor issue, but the name property for realpath is actually 'abspath'.

Python 2.7.8 on Windows 6.1.7601 (7 sp1)
msg264810 - (view) Author: (ppperry) Date: 2016-05-04 12:51
Also is true on python 3.4. Why does this matter anyway?
msg264812 - (view) Author: Berker Peksag (berker.peksag) * (Python committer) Date: 2016-05-04 13:08
It's because realpath is defined as

    # realpath is a no-op on systems without islink support
    realpath = abspath

under Windows.
History
Date User Action Args
2016-05-04 17:05:58brett.cannonsetstatus: open -> closed
resolution: not a bug
2016-05-04 13:08:18berker.peksagsetnosy: + berker.peksag
messages: + msg264812
2016-05-04 12:51:48ppperrysetnosy: + ppperry

messages: + msg264810
versions: + Python 3.4
2016-05-04 11:56:34Jon Morriscreate