classification
Title: Multiple memory leaks after raw Py_Initialize and Py_Finalize.
Type: resource usage Stage: resolved
Components: Interpreter Core Versions: Python 3.5
process
Status: closed Resolution: duplicate
Dependencies: Superseder: Py_Finalize() doesn't clear all Python objects at exit
View: 1635741
Assigned To: Nosy List: Aleksander Gajewski, serhiy.storchaka, vstinner
Priority: normal Keywords:

Created on 2016-04-29 21:14 by Aleksander Gajewski, last changed 2019-10-23 00:15 by vstinner. This issue is now closed.

Files
File name Uploaded Description Edit
python_leak.tar Aleksander Gajewski, 2016-04-29 21:14 example sources
Messages (2)
msg264522 - (view) Author: Aleksander Gajewski (Aleksander Gajewski) Date: 2016-04-29 21:14
There are a lot of memory leaks detected by AddressSanitzer (used with gcc-6.1). The sample program with its cmakelists and output can be found in the attachment. Exact list of memory leaks is placed in log_3_python_test.txt. I am using Python3.5.1 compile from sources (placed in /opt/python).
msg355190 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2019-10-23 00:15
That's basically a duplicate of bpo-1635741.
History
Date User Action Args
2019-10-23 00:15:53vstinnersetstatus: open -> closed
superseder: Py_Finalize() doesn't clear all Python objects at exit
messages: + msg355190

resolution: duplicate
stage: resolved
2016-05-02 09:42:50SilentGhostsetnosy: + vstinner, serhiy.storchaka
components: + Interpreter Core, - Library (Lib)
2016-04-29 21:14:58Aleksander Gajewskicreate