classification
Title: Remove multiple inheritance in Python 3000
Type: enhancement Stage:
Components: None Versions: Python 3.0
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: christian.heimes, draghuram, gmarketer
Priority: normal Keywords:

Created on 2008-04-22 09:52 by gmarketer, last changed 2008-04-22 12:04 by gmarketer. This issue is now closed.

Messages (4)
msg65671 - (view) Author: gmarketer (gmarketer) Date: 2008-04-22 09:52
Please remove ability to multiple inheritance in Python 3000.

Multiple inheritance is bad for design, rarely used and contains many 
problems for usual users.

Every program can be designed only with single inheritance.
msg65672 - (view) Author: Raghuram Devarakonda (draghuram) (Python triager) Date: 2008-04-22 10:54
I don't think this request is appropriate for bug tracker. If you are
really keen, bring it up on perhaps python-ideas mailing list.
msg65673 - (view) Author: Christian Heimes (christian.heimes) * (Python committer) Date: 2008-04-22 11:25
You are too late for Python 3000. You next change will be in about 10
years for Python 4000.
msg65674 - (view) Author: gmarketer (gmarketer) Date: 2008-04-22 12:04
I'm also think so.
History
Date User Action Args
2008-04-22 12:04:24gmarketersetmessages: + msg65674
2008-04-22 11:25:14christian.heimessetnosy: + christian.heimes
messages: + msg65673
2008-04-22 10:54:53draghuramsetstatus: open -> closed
resolution: not a bug
messages: + msg65672
nosy: + draghuram
2008-04-22 09:52:15gmarketercreate