classification
Title: Method Parameters can be Accepted as Keyword Arguments?
Type: behavior Stage: resolved
Components: Interpreter Core Versions: Python 3.4, Python 2.7
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: gfyoung
Priority: normal Keywords:

Created on 2016-03-16 21:12 by gfyoung, last changed 2016-03-16 21:25 by zach.ware. This issue is now closed.

Files
File name Uploaded Description Edit
bug.py gfyoung, 2016-03-16 21:12 Demonstration of the unexpected behaviour
Messages (2)
msg261862 - (view) Author: G Young (gfyoung) * Date: 2016-03-16 21:12
This issue arose as we were making changes to the 'pandas' library. I am not sure if this is a bug or feature, but it definitely did not cross anyone's minds when discussing the PR at hand. I have attached a code sample to illustrate the "bug" that I have run successfully on Python 2.7 and Python 3.4.
msg261863 - (view) Author: G Young (gfyoung) * Date: 2016-03-16 21:22
Google indicates that this is indeed a feature of the language. Sorry about that! I guess that was a miscommunication on the PR-end.
History
Date User Action Args
2016-03-16 21:25:01zach.waresetresolution: not a bug
stage: resolved
2016-03-16 21:22:34gfyoungsetstatus: open -> closed

messages: + msg261863
2016-03-16 21:12:11gfyoungcreate