classification
Title: Python rk0.3b1 KeyError: 'config_argparse_rel_path'
Type: behavior Stage: resolved
Components: Installation Versions: Python 2.7
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: berker.peksag, sherpa
Priority: normal Keywords:

Created on 2016-02-11 15:02 by sherpa, last changed 2016-02-12 03:45 by berker.peksag. This issue is now closed.

Files
File name Uploaded Description Edit
pdb_rk0.3b1.txt sherpa, 2016-02-11 15:02 python debugger trace
Messages (2)
msg260109 - (view) Author: sherpa (sherpa) Date: 2016-02-11 15:02
Hi,
we use python 2.7.3 on Linux SuSe Enterprise 11 x86 64 bits.
After installing the python module rk0.3b1, we have this error when rk parse the configuration file: KeyError: 'config_argparse_rel_path' after this function dict.__getitem__(self, key)

You will find below the debugger trace:

# python -m pdb /opt/python-2.7.3/bin/rk

> /opt/python-2.7.3/bin/rk(3)<module>()

-> __requires__ = 'rk==0.3b1'

(Pdb) cont

Traceback (most recent call last):

  File "/opt/python-2.7.3/lib/python2.7/pdb.py", line 1314, in main

    pdb._runscript(mainpyfile)

  File "/opt/python-2.7.3/lib/python2.7/pdb.py", line 1233, in _runscript

    self.run(statement)

  File "/opt/python-2.7.3/lib/python2.7/bdb.py", line 387, in run

    exec cmd in globals, locals

  File "<string>", line 1, in <module>

  File "/opt/python-2.7.3/bin/rk", line 3, in <module>

    __requires__ = 'rk==0.3b1'

  File "build/bdist.linux-x86_64/egg/rk/rk.py", line 253, in main

    create_dictionaries()

  File "build/bdist.linux-x86_64/egg/rk/rk.py", line 25, in create_dictionaries

    config_argparse_rel_path = config["config_argparse_rel_path"]

  File "/opt/python-2.7.3/lib/python2.7/site-packages/configobj.py", line 554, in __getitem__

    val = dict.__getitem__(self, key)

KeyError: 'config_argparse_rel_path'

Uncaught exception. Entering post mortem debugging

Running 'cont' or 'step' will restart the program

> /opt/python-2.7.3/lib/python2.7/site-packages/configobj.py(554)__getitem__()

-> val = dict.__getitem__(self, key)

(Pdb)
msg260158 - (view) Author: Berker Peksag (berker.peksag) * (Python committer) Date: 2016-02-12 03:45
Thanks for the report, but both rk and configobj are not part of the Python standard library. Please use their issue tracker to report your problem.
History
Date User Action Args
2016-02-12 03:45:38berker.peksagsetstatus: open -> closed

nosy: + berker.peksag
messages: + msg260158

resolution: not a bug
stage: resolved
2016-02-11 15:02:01sherpacreate