classification
Title: os.startfile implementation for other OS'es besides Windows
Type: enhancement Stage: resolved
Components: Library (Lib) Versions: Python 3.6
process
Status: closed Resolution: duplicate
Dependencies: Superseder: Add shutil.open
View: 3177
Assigned To: Nosy List: Elizacat, r.david.murray
Priority: normal Keywords:

Created on 2015-11-24 23:46 by Elizacat, last changed 2015-11-25 00:21 by Elizacat. This issue is now closed.

Messages (3)
msg255306 - (view) Author: Elizabeth Myers (Elizacat) * Date: 2015-11-24 23:46
os.startfile can be implemented on other OS'es besides Windows relatively easily (although the operation parameter should probably be limited to Windows; it can be implemented elsewhere, but is probably not worth the trouble).

On Unix-like operating systems besides OS X, an attempt to use xdg-open can be used and will attempt to open the file in a chosen program; this is the freedesktop.org standard open utility. See also http://linux.die.net/man/1/xdg-open and https://wiki.archlinux.org/index.php/Xdg-open (not specific to ArchLinux).

On OS X, open can be used, with similar results to xdg-open (in fact, xdg-open seems inspired by it). See also https://developer.apple.com/library/mac/documentation/Darwin/Reference/ManPages/man1/open.1.html.
msg255307 - (view) Author: R. David Murray (r.david.murray) * (Python committer) Date: 2015-11-24 23:57
Duplicate of Issue 3177, which has quite a bit of discussion and some patch proposals.  You might want to add yourself as nosy to that issue and see what you think of the proposals (I did not read through it to see what the status is...there hasn't been any activity on it for a long time, so it is ripe for someone new to pick it up and carry it forward).
msg255311 - (view) Author: Elizabeth Myers (Elizacat) * Date: 2015-11-25 00:21
I'm not going to reopen that can of worms.

Sorry to waste your time.
History
Date User Action Args
2015-11-25 00:21:19Elizacatsetmessages: + msg255311
2015-11-24 23:57:41r.david.murraysetstatus: open -> closed

superseder: Add shutil.open

nosy: + r.david.murray
messages: + msg255307
resolution: duplicate
stage: resolved
2015-11-24 23:46:04Elizacatcreate