classification
Title: implement address in network in ipaddress module
Type: enhancement Stage: resolved
Components: Library (Lib) Versions: Python 3.6
process
Status: closed Resolution: duplicate
Dependencies: Superseder: containment test for "ip_network in ip_network"
View: 20825
Assigned To: Nosy List: berker.peksag, gescheit, ncoghlan, pmoody
Priority: normal Keywords: patch

Created on 2015-10-17 13:38 by gescheit, last changed 2016-07-26 19:00 by berker.peksag. This issue is now closed.

Files
File name Uploaded Description Edit
ipaddress_contains_network.patch gescheit, 2015-10-17 13:38
Messages (3)
msg253128 - (view) Author: Aleksandr Balezin (gescheit) * Date: 2015-10-17 13:38
Current realization of _BaseNetwork.__contains__ always returns False if other is _BaseNetwork. This patch implements proper comparison of _BaseNetwork objects.
msg262580 - (view) Author: Aleksandr Balezin (gescheit) * Date: 2016-03-28 19:39
Any news?
msg271407 - (view) Author: Berker Peksag (berker.peksag) * (Python committer) Date: 2016-07-26 19:00
Thanks for the report and for the patch, Aleksandr. This is a duplicate of issue 20825. See also issue 27628 for a similar report.
History
Date User Action Args
2016-07-26 19:00:29berker.peksagsetstatus: open -> closed

dependencies: - speed up ipaddress __contain__ method
superseder: containment test for "ip_network in ip_network"

nosy: + berker.peksag
messages: + msg271407
resolution: duplicate
stage: patch review -> resolved
2016-03-28 19:39:01gescheitsetmessages: + msg262580
2015-10-17 18:00:13serhiy.storchakasetversions: - Python 3.4, Python 3.5
nosy: + ncoghlan, pmoody

dependencies: + speed up ipaddress __contain__ method
type: enhancement
stage: patch review
2015-10-17 16:44:58gescheitsetversions: + Python 3.4, Python 3.6
2015-10-17 13:38:12gescheitcreate