classification
Title: https://docs.python.org/library should redirect to Python 3 doc
Type: enhancement Stage: resolved
Components: Documentation, Library (Lib) Versions:
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: docs@python Nosy List: Martín Gaitán, docs@python, zach.ware
Priority: normal Keywords:

Created on 2015-09-11 04:21 by Martín Gaitán, last changed 2015-09-11 04:57 by zach.ware. This issue is now closed.

Messages (2)
msg250442 - (view) Author: Martín Gaitán (Martín Gaitán) Date: 2015-09-11 04:21
The canonical link for documentation https://docs.python.org/ redirect to the index page of the stable Python 3's documentation 

However, https://docs.python.org/library still redirects to the Python 2 standard lib's docs. 

To be consequent https://docs.python.org/library should redirect to https://docs.python.org/3/library/
msg250450 - (view) Author: Zachary Ware (zach.ware) * (Python committer) Date: 2015-09-11 04:57
This is by design, see PEP 430 for rationale.  Eventually the Python 3 docs will be the default, but that day isn't quite here yet.
History
Date User Action Args
2015-09-11 04:57:09zach.waresetstatus: open -> closed

nosy: + zach.ware
messages: + msg250450

resolution: not a bug
stage: resolved
2015-09-11 04:21:31Martín Gaitáncreate