classification
Title: Py_Finalize doesn't clean up PyImport_Inittab
Type: crash Stage:
Components: Versions: Python 3.6
process
Status: closed Resolution: fixed
Dependencies: Superseder:
Assigned To: Nosy List: Alex Budovski, ncoghlan, smcv, vstinner, xiang.zhang
Priority: normal Keywords:

Created on 2015-08-13 02:10 by Alex Budovski, last changed 2016-08-17 14:26 by vstinner. This issue is now closed.

Messages (5)
msg248495 - (view) Author: Alex Budovski (Alex Budovski) Date: 2015-08-13 02:10
This means initialize/run script/finalize will crash the second time, since the inittab can have stale entries.
msg272425 - (view) Author: Simon McVittie (smcv) Date: 2016-08-11 08:51
http://bugs.python.org/issue27736 might be related, or even a duplicate of this.
msg272925 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2016-08-17 12:06
> This means initialize/run script/finalize will crash the second time, since the inittab can have stale entries.

Sorry, I don't understand. inittab: do you mean _PyImport_Inittab defined in Modules/config.c or PC/config.c? This table is constant, no?

Are you able to reproduce a crash?

I suggest to close the issue as not a bug :-p
msg272947 - (view) Author: Xiang Zhang (xiang.zhang) * (Python committer) Date: 2016-08-17 14:18
> initialize/run script/finalize will crash the second time

I don't think so since we already get a test case in test_capi that does init/fini repeatedly. It does not crash.

So I agree to close this one.
msg272953 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2016-08-17 14:26
The issue was fixed by a previous change, maybe the issue #27736.
History
Date User Action Args
2016-08-17 14:26:11vstinnersetstatus: open -> closed
resolution: fixed
messages: + msg272953
2016-08-17 14:18:39xiang.zhangsetmessages: + msg272947
2016-08-17 12:06:30vstinnersetnosy: + vstinner
messages: + msg272925
2016-08-16 15:28:04xiang.zhangsetnosy: + xiang.zhang
2016-08-11 08:51:36smcvsetnosy: + smcv
messages: + msg272425
2015-08-13 17:41:02pitrousetnosy: + ncoghlan
2015-08-13 02:10:34Alex Budovskicreate