classification
Title: stat.ST_CTIME and stat.ST_ATIME problem
Type: Stage:
Components: Library (Lib) Versions: Python 2.5
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: gpolo, sassas
Priority: normal Keywords:

Created on 2008-03-22 02:25 by sassas, last changed 2008-05-25 09:18 by gregory.p.smith. This issue is now closed.

Messages (2)
msg64310 - (view) Author: Andrey Skvortsov (sassas) Date: 2008-03-22 02:25
stat.ST_CTIME and stat.ST_ATIME are mixed up.
ST_CTIME gives access time and should be ST_ATIME and vice versa 
ST_ATIME gives creation time. Linux.
msg64905 - (view) Author: Guilherme Polo (gpolo) * (Python committer) Date: 2008-04-03 20:22
Not here, ST_CTIME is 9 and ST_ATIME is 7, both are the correct indices
at the tuple returned by os.stat.

Could you recheck that and then and include some output (if it is really
incorrect) ?
History
Date User Action Args
2008-05-25 09:18:01gregory.p.smithsetstatus: open -> closed
resolution: not a bug
2008-04-03 20:22:16gpolosetnosy: + gpolo
messages: + msg64905
2008-03-22 02:25:15sassascreate