classification
Title: Fail to build time module on Mac
Type: compile error Stage: resolved
Components: macOS Versions: Python 3.6
process
Status: closed Resolution: works for me
Dependencies: Superseder:
Assigned To: Nosy List: ned.deily, ronaldoussoren, vajrasky, zach.ware
Priority: normal Keywords: patch

Created on 2015-06-04 15:17 by vajrasky, last changed 2015-06-04 15:36 by ned.deily. This issue is now closed.

Files
File name Uploaded Description Edit
fix_fail_build_time_module.patch vajrasky, 2015-06-04 15:17 review
Messages (4)
msg244827 - (view) Author: Vajrasky Kok (vajrasky) * Date: 2015-06-04 15:17
On my OSX Yosemite 10 with GCC 4.2.1 Compatible Apple LLVM 6.1.0 (clang-602.0.53), I fail to build time module.

Failed to build these modules:
time

Here is the patch to fix the compile error.
msg244828 - (view) Author: Vajrasky Kok (vajrasky) * Date: 2015-06-04 15:21
Here is the error message:
building 'time' extension
gcc -Wno-unused-result -Wsign-compare -g -O0 -Wall -Wstrict-prototypes -Werror=declaration-after-statement -I./Include -I. -IInclude -I/usr/local/include -I/Users/sky/Code/python/cpython/Include -I/Users/sky/Code/python/cpython -c /Users/sky/Code/python/cpython/Modules/timemodule.c -o build/temp.macosx-10.9-x86_64-3.6-pydebug/Users/sky/Code/python/cpython/Modules/timemodule.o
/Users/sky/Code/python/cpython/Modules/timemodule.c:656:9: error: use of undeclared identifier '_Py_BEGIN_SUPPRESS_IPH'
        _Py_BEGIN_SUPPRESS_IPH
        ^
/Users/sky/Code/python/cpython/Modules/timemodule.c:659:9: error: use of undeclared identifier '_Py_END_SUPPRESS_IPH'
        _Py_END_SUPPRESS_IPH
        ^
2 errors generated.
msg244829 - (view) Author: Zachary Ware (zach.ware) * (Python committer) Date: 2015-06-04 15:31
See discussion on #24244, I think this is an issue with your checkout rather than the code.
msg244830 - (view) Author: Ned Deily (ned.deily) * (Python committer) Date: 2015-06-04 15:36
Yes, try "make distclean".  I am unable to reproduce the problem and don't see why your proposed patch would make a difference.
History
Date User Action Args
2015-06-04 15:36:07ned.deilysetstatus: pending -> closed
resolution: works for me
messages: + msg244830

stage: resolved
2015-06-04 15:31:49zach.waresetstatus: open -> pending
nosy: + zach.ware
messages: + msg244829

2015-06-04 15:21:29vajraskysetmessages: + msg244828
2015-06-04 15:17:50vajraskycreate