classification
Title: Fixer for filter(None, ...) -> filter(bool, ...)
Type: Stage:
Components: 2to3 (2.x to 3.x conversion tool) Versions: Python 2.6
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: rhettinger Nosy List: brett.cannon, collinwinter, rhettinger
Priority: critical Keywords: 26backport

Created on 2008-03-17 19:53 by brett.cannon, last changed 2008-03-17 22:31 by rhettinger. This issue is now closed.

Messages (2)
msg63742 - (view) Author: Brett Cannon (brett.cannon) * (Python committer) Date: 2008-03-17 19:53
A fixer to go from filter(None, ..) to filter(bool, ..) is needed.
msg63793 - (view) Author: Raymond Hettinger (rhettinger) * (Python committer) Date: 2008-03-17 22:31
There was no change to filter().  It still accepts None.  Hence, there
is no need for a fixer.
History
Date User Action Args
2008-03-17 22:31:12rhettingersetstatus: open -> closed
resolution: not a bug
messages: + msg63793
2008-03-17 20:16:46brett.cannonsetpriority: release blocker -> critical
2008-03-17 20:04:54rhettingersetassignee: collinwinter -> rhettinger
nosy: + rhettinger
2008-03-17 19:53:14brett.cannoncreate