classification
Title: Python 3.4 and 2.7 installation no Script folder and no pip installed
Type: behavior Stage:
Components: Installation, Windows Versions: Python 3.4
process
Status: closed Resolution: fixed
Dependencies: Superseder:
Assigned To: Nosy List: BreamoreBoy, Daiyue Weng, steve.dower, tim.golden, zach.ware
Priority: normal Keywords:

Created on 2015-03-07 20:48 by Daiyue Weng, last changed 2015-03-09 11:47 by Daiyue Weng. This issue is now closed.

Messages (3)
msg237476 - (view) Author: Daiyue Weng (Daiyue Weng) Date: 2015-03-07 20:48
Hi, I was doing a fresh installation for Python 2.7.9 (32 bit) and 3.4.3 (32 bit) (downloaded from PSF) on Win7 X64 today, and I found that there is no 'Script' folder in 'Python27' and 'Python34' folder as first child level folder, but there is one in Tools. However, I couldn't find pip within that 'Script' folder, although pip should be installed with Python by default. The other I was doing the same installation for my other PC and laptop, there was 'Script' folder (as first level child folder in 'Python27' and 'Python34') containing pip. So what is going on? how to install pip and maybe other useful scripts this way? 

'C:\Pythonxy\Lib\site-packages' contains nothing but a README file. I tried 'python -m ensurepip' in 'C:\Python34'. I got the following errors: 

Ignoring indexes: https://pypi.python.org/simple 
Collecting setuptools 
 Exception: 
 Traceback (most recent call last): 
File "C:\Users\daiyue\AppData\Local\Temp\tmppvmc8dv1\pip-6.0.8-py2.py3-none- 
any.whl\pip\basecommand.py", line 232, in main 
  status = self.run(options, args) 
File "C:\Users\daiyue\AppData\Local\Temp\tmppvmc8dv1\pip-6.0.8-py2.py3-none- 
any.whl\pip\commands\install.py", line 339, in run 
  requirement_set.prepare_files(finder) 
File "C:\Users\daiyue\AppData\Local\Temp\tmppvmc8dv1\pip-6.0.8-py2.py3-none- 
any.whl\pip\req\req_set.py", line 333, in prepare_files 
  upgrade=self.upgrade, 
File "C:\Users\daiyue\AppData\Local\Temp\tmppvmc8dv1\pip-6.0.8-py2.py3-none- 
any.whl\pip\index.py", line 326, in find_requirement 
  file_locations, url_locations = self._sort_locations(locations) 
File "C:\Users\daiyue\AppData\Local\Temp\tmppvmc8dv1\pip-6.0.8-py2.py3-none- 
any.whl\pip\index.py", line 158, in _sort_locations 
  sort_path(os.path.join(path, item)) 
File "C:\Users\daiyue\AppData\Local\Temp\tmppvmc8dv1\pip-6.0.8-py2.py3-none- 
any.whl\pip\index.py", line 139, in sort_path 
  if mimetypes.guess_type(url, strict=False)[0] == 'text/html': 
File "C:\Python34\lib\mimetypes.py", line 287, in guess_type 
  init() 
File "C:\Python34\lib\mimetypes.py", line 348, in init 
  db.read_windows_registry() 
File "C:\Python34\lib\mimetypes.py", line 255, in read_windows_registry 
  with _winreg.OpenKey(hkcr, subkeyname) as subkey: 
TypeError: OpenKey() argument 2 must be str without null characters or None,  not str 

I also tried 'python -m ensurepip' in 'C:\Python27'. I got some errors in Users\user_name\pip log file:

------------------------------------------------------------
C:\Python27\lib\ensurepip\__main__.py run on 03/07/15 01:47:03
Ignoring indexes: https://pypi.python.org/simple/
Downloading/unpacking setuptools
Cleaning up...
  Removing temporary dir c:\users\daiyue\appdata\local\temp\pip_build_daiyue...
Exception:
Traceback (most recent call last):
  File "c:\users\daiyue\appdata\local\temp\tmpxji_co\pip-1.5.6-py2.py3-none-any.whl\pip\basecommand.py", line 122, in main
    status = self.run(options, args)
  File "c:\users\daiyue\appdata\local\temp\tmpxji_co\pip-1.5.6-py2.py3-none-any.whl\pip\commands\install.py", line 278, in run
    requirement_set.prepare_files(finder, force_root_egg_info=self.bundle, bundle=self.bundle)
  File "c:\users\daiyue\appdata\local\temp\tmpxji_co\pip-1.5.6-py2.py3-none-any.whl\pip\req.py", line 1177, in prepare_files
    url = finder.find_requirement(req_to_install, upgrade=self.upgrade)
  File "c:\users\daiyue\appdata\local\temp\tmpxji_co\pip-1.5.6-py2.py3-none-any.whl\pip\index.py", line 209, in find_requirement
    file_locations, url_locations = self._sort_locations(locations)
  File "c:\users\daiyue\appdata\local\temp\tmpxji_co\pip-1.5.6-py2.py3-none-any.whl\pip\index.py", line 128, in _sort_locations
    sort_path(os.path.join(path, item))
  File "c:\users\daiyue\appdata\local\temp\tmpxji_co\pip-1.5.6-py2.py3-none-any.whl\pip\index.py", line 109, in sort_path
    if mimetypes.guess_type(url, strict=False)[0] == 'text/html':
  File "C:\Python27\lib\mimetypes.py", line 290, in guess_type
    init()
  File "C:\Python27\lib\mimetypes.py", line 351, in init
    db.read_windows_registry()
  File "C:\Python27\lib\mimetypes.py", line 254, in read_windows_registry
    with _winreg.OpenKey(hkcr, subkeyname) as subkey:
TypeError: must be string without null bytes or None, not str
 

I have also tried out 64bit Python installation, but got the same result. So how to fix this? I posted the same message on comp.lang.python and Python Google group with no response so I guess i may try some luck here.

cheers
msg237628 - (view) Author: Tim Golden (tim.golden) * (Python committer) Date: 2015-03-09 10:14
This is a duplicate of issue22028. 

Daiyue Weng: to move forward, can you apply the fix referred to in this post:

https://mail.python.org/pipermail/python-list/2015-January/696688.html

(ie the "removing corrupted keys" section from http://www.swarley.me.uk/blog/2014/04/23/python-pip-and-windows-registry-corruption/).

Steve: if you can, please commit your change from issue22028; I just don't have the time at the moment to run up a clone and test it, but it looks safe to me.
msg237638 - (view) Author: Daiyue Weng (Daiyue Weng) Date: 2015-03-09 11:47
The fix that referred to another thread solved my issue completely.

thanks
History
Date User Action Args
2015-03-09 11:47:38Daiyue Wengsetstatus: open -> closed
resolution: fixed
messages: + msg237638
2015-03-09 10:25:27BreamoreBoysetnosy: + BreamoreBoy
2015-03-09 10:14:02tim.goldensetmessages: + msg237628
2015-03-07 22:33:24SilentGhostsetnosy: + tim.golden, zach.ware, steve.dower
components: + Installation, Windows, - Extension Modules
2015-03-07 20:48:32Daiyue Wengcreate