classification
Title: file.read() followed by file.write() result in incorrect behavior
Type: Stage:
Components: IO Versions: Python 3.2, Python 3.3, Python 3.4, Python 3.5
process
Status: closed Resolution: duplicate
Dependencies: Superseder: TextIOWrapper: issues with interlaced read-write
View: 12215
Assigned To: Nosy List: Maxime S, vstinner
Priority: normal Keywords:

Created on 2015-03-02 14:37 by Maxime S, last changed 2015-03-02 15:45 by r.david.murray. This issue is now closed.

Messages (2)
msg237046 - (view) Author: Maxime S (Maxime S) * Date: 2015-03-02 14:37
Observed Behavior:

$python3
Python 3.5.0a1+ (default, Mar  2 2015, 14:30:05) 
[GCC 4.6.3] on linux
Type "help", "copyright", "credits" or "license" for more information.
>>> f = open("test", "w+")
>>> f.write("Hello World")
11
>>> f.seek(0)
0
>>> f.read(5)
'Hello'
>>> f.write(" people")
7
>>> f.seek(0)
0
>>> f.read()
'Hello World people'


Expected Behavior

According to POSIX, the last f.read() should return "Hello people", like in Python 2:


$ python2
Python 2.7.3 (default, Feb 27 2014, 20:00:17) 
[GCC 4.6.3] on linux2
Type "help", "copyright", "credits" or "license" for more information.
>>> f = open("test", "w+")
>>> f.write("Hello World")
>>> f.seek(0)
>>> f.read(5)
'Hello'
>>> f.write(" people")
>>> f.seek(0)
>>> f.read()
'Hello people'

Workaround:

f.seek(f.tell()) immediately after f.read(5) restore the correct behavior.
msg237047 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2015-03-02 14:50
This issue is probably a duplicate of the issue #12215 (see also #12513 for the codecs moduile).
History
Date User Action Args
2015-03-02 15:45:52r.david.murraysetstatus: open -> closed
superseder: TextIOWrapper: issues with interlaced read-write
resolution: duplicate
2015-03-02 14:50:03vstinnersetnosy: + vstinner
messages: + msg237047
2015-03-02 14:37:41Maxime Screate