classification
Title: multiprocessing documentation - little more examples for parallel computing
Type: enhancement Stage: resolved
Components: Documentation Versions: Python 2.7
process
Status: closed Resolution: duplicate
Dependencies: Superseder: multiprocessing doc organization impedes understanding
View: 23100
Assigned To: docs@python Nosy List: Cezary.Wagner, davin, docs@python
Priority: normal Keywords:

Created on 2015-02-24 17:12 by Cezary.Wagner, last changed 2020-05-31 13:11 by serhiy.storchaka. This issue is now closed.

Messages (3)
msg236519 - (view) Author: Cezary Wagner (Cezary.Wagner) Date: 2015-02-24 17:12
I am little confused with multiprocessing documentation since it does not contain enough examples.

Parallel computing is not simple by design so documentation can be little improved to make it simpler. No pattern to use pool with classes. No pattern to exchange objects between processes. Understanding usage of Queue and SimpleQueue or JoinableQueue is not very clear.

Current documentation in majority is good reference with very rare examples / patterns.
msg236523 - (view) Author: Davin Potts (davin) * (Python committer) Date: 2015-02-24 17:27
This is a specific suggestion that should be included / addressed as part of issue23100.
msg236524 - (view) Author: Cezary Wagner (Cezary.Wagner) Date: 2015-02-24 17:30
Should I add this suggestion to open before issue?

I started doing multiprocessing code in Python so I can have more suggestions since I found that documentation can be improved I will report specific problem.
History
Date User Action Args
2020-05-31 13:11:27serhiy.storchakasetstatus: open -> closed
superseder: multiprocessing doc organization impedes understanding
resolution: duplicate
stage: resolved
2015-02-24 17:30:03Cezary.Wagnersetmessages: + msg236524
2015-02-24 17:27:47davinsetnosy: + davin
type: enhancement
messages: + msg236523
2015-02-24 17:12:26Cezary.Wagnersetversions: + Python 2.7
2015-02-24 17:12:19Cezary.Wagnercreate