classification
Title: Idle Application Not Responding
Type: Stage: resolved
Components: IDLE, macOS Versions: Python 3.4
process
Status: closed Resolution: out of date
Dependencies: Superseder:
Assigned To: Nosy List: hynek, ned.deily, ronaldoussoren, terry.reedy, ww0115
Priority: normal Keywords:

Created on 2015-02-10 07:09 by ww0115, last changed 2017-06-19 21:52 by terry.reedy. This issue is now closed.

Messages (3)
msg235675 - (view) Author: ww0115 (ww0115) Date: 2015-02-10 07:09
I recently downloaded Python 3.4 on my Mac (running on Yosemite 10.10.2) and every time I try and open Idle, the icon just keeps jumping and the application never opens. When I click on the icon after it stops jumping it just says "Application Not Responding". I've also tried downloading ActiveTCL to see if it helps but it doesn't as that application doesn't open either. Any suggestions?
msg235723 - (view) Author: Ned Deily (ned.deily) * (Python committer) Date: 2015-02-11 03:09
Try launching IDLE from a Terminal window command line shell with:

/usr/local/bin/python3.4 -m idlelib

and see if any error messages are reported.  Also please report what is printed when this is run in a command shell:

/usr/local/bin/python3.4 -c 'import sys;print(sys.version)'
msg296380 - (view) Author: Terry J. Reedy (terry.reedy) * (Python committer) Date: 2017-06-19 21:52
No followup, no issue.  If IDLE did not run but python did, the next thing to have tried would have been 
.../python3.4 -c "import tkinter; tkinter.Tk()"
History
Date User Action Args
2017-06-19 21:52:35terry.reedysetstatus: open -> closed

nosy: + terry.reedy
messages: + msg296380

resolution: out of date
stage: resolved
2015-02-11 03:09:23ned.deilysetmessages: + msg235723
2015-02-10 08:18:49SilentGhostsetnosy: + ronaldoussoren, ned.deily, hynek
components: + macOS
2015-02-10 07:09:16ww0115create