classification
Title: [Windows] asyncio: add UDP support to ProactorEventLoop
Type: enhancement Stage: resolved
Components: asyncio, Windows Versions: Python 3.4, Python 3.5
process
Status: closed Resolution: duplicate
Dependencies: Superseder: asyncio: Windows Proactor Event Loop UDP Support
View: 29883
Assigned To: Nosy List: gvanrossum, steve.dower, tim.golden, vstinner, yselivanov, zach.ware
Priority: normal Keywords:

Created on 2015-01-21 23:40 by vstinner, last changed 2018-09-14 19:30 by vstinner. This issue is now closed.

Messages (3)
msg234456 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2015-01-21 23:40
ProactorEventLoop lacks UDP support: create_datagram_endpoint() is not supported.

New functions should be added to the _overlapped modul. Example: add maybe WSARecvFrom()?
msg234533 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2015-01-23 01:27
See also https://code.google.com/p/tulip/issues/detail?id=187
msg325386 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2018-09-14 19:30
Duplicate of bpo-29883.
History
Date User Action Args
2018-09-14 19:30:38vstinnersetstatus: open -> closed
superseder: asyncio: Windows Proactor Event Loop UDP Support
messages: + msg325386

resolution: duplicate
stage: resolved
2015-01-23 01:27:42vstinnersetmessages: + msg234533
2015-01-22 08:19:39vstinnersettype: enhancement
2015-01-21 23:40:13vstinnercreate