classification
Title: Class **kwds broken (PEP 3115)
Type: behavior Stage:
Components: Interpreter Core Versions: Python 3.0
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: jackdied Nosy List: jackdied
Priority: normal Keywords:

Created on 2008-03-17 17:24 by jackdied, last changed 2008-03-17 19:33 by jackdied. This issue is now closed.

Messages (2)
msg63681 - (view) Author: Jack Diederich (jackdied) * (Python committer) Date: 2008-03-17 17:24
typeobject.c:type_new only allows 0 or 1 keyword arg in class creation
instead of an arbitrary number as per PEP3115.

I'm working on a patch.
msg63727 - (view) Author: Jack Diederich (jackdied) * (Python committer) Date: 2008-03-17 19:33
Not a bug.

If you pass arbitrary keywords in class construction you have to define
__new__ and __init__ on the metaclass to handle them.
History
Date User Action Args
2008-03-17 19:33:11jackdiedsetstatus: open -> closed
resolution: not a bug
messages: + msg63727
2008-03-17 17:24:19jackdiedcreate