classification
Title: Clean up getargs.c and its formatting possibilities
Type: behavior Stage:
Components: Interpreter Core Versions: Python 3.0
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: georg.brandl Nosy List: barry, benjamin.peterson, brett.cannon, georg.brandl
Priority: release blocker Keywords:

Created on 2008-03-17 16:27 by brett.cannon, last changed 2008-09-04 03:19 by barry. This issue is now closed.

Messages (6)
msg63665 - (view) Author: Brett Cannon (brett.cannon) * (Python committer) Date: 2008-03-17 16:27
It was mentioned by Georg on python-3000 that getargs.c needs to be
cleaned up and worked on before Python 3.0 goes out the door.
msg70454 - (view) Author: Benjamin Peterson (benjamin.peterson) * (Python committer) Date: 2008-07-31 01:51
Hmm. I suppose this is still an issue. Should it be a release blocker yet?
msg72456 - (view) Author: Barry A. Warsaw (barry) * (Python committer) Date: 2008-09-04 01:55
Is there more information on this?  Where's the referenced article and
what exactly needs to get done?  Deferring this for rc1.
msg72473 - (view) Author: Barry A. Warsaw (barry) * (Python committer) Date: 2008-09-04 02:57
Since I'm going to postpone rc1 anyway, might as well bump this back to
release blocker for now.
msg72474 - (view) Author: Brett Cannon (brett.cannon) * (Python committer) Date: 2008-09-04 03:11
This was an issue created at PyCon when I just went through every single
thing I could think of. It might not even be that relevant anymore.
msg72475 - (view) Author: Barry A. Warsaw (barry) * (Python committer) Date: 2008-09-04 03:19
As discussed with Brett on irc, closing this.
History
Date User Action Args
2008-09-04 03:19:50barrysetstatus: open -> closed
resolution: not a bug
messages: + msg72475
2008-09-04 03:11:08brett.cannonsetmessages: + msg72474
2008-09-04 02:57:53barrysetpriority: deferred blocker -> release blocker
messages: + msg72473
2008-09-04 01:55:48barrysetpriority: release blocker -> deferred blocker
nosy: + barry
messages: + msg72456
2008-08-21 14:59:15benjamin.petersonsetpriority: critical -> release blocker
2008-07-31 01:51:56benjamin.petersonsetnosy: + benjamin.peterson
messages: + msg70454
2008-03-21 20:47:15georg.brandllinkissue2298 superseder
2008-03-17 20:08:13brett.cannonsetpriority: release blocker -> critical
2008-03-17 16:27:50brett.cannoncreate