classification
Title: Crash Error?
Type: crash Stage:
Components: IDLE Versions: Python 3.3
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: E.Roberts, vstinner
Priority: normal Keywords:

Created on 2014-12-12 11:58 by E.Roberts, last changed 2014-12-12 12:02 by vstinner. This issue is now closed.

Files
File name Uploaded Description Edit
python error.png E.Roberts, 2014-12-12 11:58
Messages (2)
msg232531 - (view) Author: E Roberts (E.Roberts) Date: 2014-12-12 11:58
New to the world of Python. The picture attached is an error that a teacher at my school is receiving when he tries to run anything in IDLE.

I know nothing about coding/python/idle or anything of that nature. 

Sorry I am of little help.

Please can someone help me out with this error and provide any help or an answer. 

Thank you for dealing with a complete novice.
msg232532 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2014-12-12 12:02
The problem is that your student created a file called random.py which conflicts with the module "random" of the Python standard library. Please rename the random.py file to random.py and remove .pyc files (ex: random.pyc or __pycache__/random*pyc).
History
Date User Action Args
2014-12-12 12:02:02vstinnersetstatus: open -> closed

nosy: + vstinner
messages: + msg232532

resolution: not a bug
2014-12-12 11:58:21E.Robertscreate