classification
Title: Segfault on recursive itertools.chain.from_iterable
Type: Stage: resolved
Components: Library (Lib) Versions: Python 3.4
process
Status: closed Resolution: duplicate
Dependencies: Superseder: deeply nested filter segfaults
View: 14010
Assigned To: Nosy List: ikelly, serhiy.storchaka
Priority: normal Keywords:

Created on 2014-11-21 18:42 by ikelly, last changed 2014-11-21 19:08 by serhiy.storchaka. This issue is now closed.

Messages (2)
msg231489 - (view) Author: Ian Kelly (ikelly) Date: 2014-11-21 18:42
I expect this should result in a recursion depth exceeded error, not a segmentation fault.

$ cat test.py
import itertools

l = []
it = itertools.chain.from_iterable(l)
l.append(it)
next(it)
$ python3 test.py
Segmentation fault (core dumped)
msg231491 - (view) Author: Serhiy Storchaka (serhiy.storchaka) * (Python committer) Date: 2014-11-21 19:08
This is a duplicate of issue14010.
History
Date User Action Args
2014-11-21 19:08:29serhiy.storchakasetstatus: open -> closed

superseder: deeply nested filter segfaults

nosy: + serhiy.storchaka
messages: + msg231491
resolution: duplicate
stage: resolved
2014-11-21 18:42:52ikellycreate