classification
Title: Cache error
Type: behavior Stage: resolved
Components: Extension Modules Versions: Python 2.7
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: smoneck
Priority: normal Keywords:

Created on 2014-10-27 10:16 by smoneck, last changed 2014-10-27 19:15 by r.david.murray. This issue is now closed.

Messages (3)
msg230065 - (view) Author: Stephan Monecke (smoneck) Date: 2014-10-27 10:16
`python2 test.py` results in the following error:

Traceback (most recent call last):
  File "test.py", line 1, in <module>
    import seaborn as sns
  File "/path/seaborn.py", line 4, in <module>
    sns.set(style="ticks")
AttributeError: 'module' object has no attribute 'set'

seaborn.py is an old plot-file thats already deleted.
msg230066 - (view) Author: Stephan Monecke (smoneck) Date: 2014-10-27 10:17
Edit: test.py contains just "import seaborn as sns"
msg230069 - (view) Author: Stephan Monecke (smoneck) Date: 2014-10-27 11:01
Problem found. Induced by a .pyc file in the folder.
History
Date User Action Args
2014-10-27 19:15:52r.david.murraysettype: crash -> behavior
stage: resolved
2014-10-27 11:37:02georg.brandlsetstatus: open -> closed
resolution: not a bug
2014-10-27 11:01:06smonecksetmessages: + msg230069
2014-10-27 10:17:34smonecksetmessages: + msg230066
2014-10-27 10:16:13smoneckcreate