classification
Title: issue with PYTHON_FOR_BUILD
Type: compile error Stage: resolved
Components: Cross-Build Versions: Python 3.4
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: Alex.Willmer, Arfrever, bill9889, doko, iritkatriel, ned.deily
Priority: normal Keywords:

Created on 2014-10-16 21:09 by bill9889, last changed 2021-06-22 14:00 by iritkatriel. This issue is now closed.

Messages (10)
msg229553 - (view) Author: Billy (bill9889) Date: 2014-10-16 21:09
Hi all,

I've been cross-compiling Python3.4.1, but I have a issue than is following:

_PYTHON_PROJECT_BASE=/home/aphillips/work/leo368-20141008/fs/apps/python-3.4.1/arm _PYTHON_HOST_PLATFORM=linux-arm PYTHONPATH=../src/Lib:../src/Lib/plat-linux  -S -m  sysconfig --generate-posix-vars ; \
	if test $? -ne 0 ; then \
		echo "generate-posix-vars failed" ; \
		rm -f ./pybuilddir.txt ; \
		exit 1 ; \
	fi
/bin/sh: -S: command not found
generate-posix-vars failed
make[1]: *** [pybuilddir.txt] Error 1

If who knows about that, could you help me.

Best regards.
msg229554 - (view) Author: Arfrever Frehtes Taifersar Arahesis (Arfrever) * (Python triager) Date: 2014-10-16 21:21
You should have gotten error by:
AC_MSG_ERROR([python$PACKAGE_VERSION interpreter not found])

Have you applied any changes in Python (e.g. in configure.ac)?
msg229555 - (view) Author: Billy (bill9889) Date: 2014-10-16 21:28
Yes, I applied a patch in the configure for than it can make the configuration.
msg229556 - (view) Author: Ned Deily (ned.deily) * (Python committer) Date: 2014-10-16 21:29
And to see that message you need to rerun ./configure before running make.  Have you just updated to Python 3.4.2?  There were some changes in this area that might have inadvertently affected cross-compiles (in particular, Issue21166).
msg229557 - (view) Author: Arfrever Frehtes Taifersar Arahesis (Arfrever) * (Python triager) Date: 2014-10-16 21:30
What changes exactly have you made in Python?
msg229558 - (view) Author: Billy (bill9889) Date: 2014-10-16 21:37
Ned Deil,

For my application I need to use Python 3.4.1 and Why do I need to run the ./configure for second time?.
msg229559 - (view) Author: Ned Deily (ned.deily) * (Python committer) Date: 2014-10-16 21:44
The "generate-posix-vars failed" message you show is not in Python 3.4.1; it was added recently by e52d85f2e284 for Issue21166 and is first released in 3.4.2.  So it's hard to tell exactly what you are building with.
msg229561 - (view) Author: Billy (bill9889) Date: 2014-10-16 21:53
I added a patch for the resolution of the issue but it didn't work. You can see in my first comment than there is a issue with PYTHONPATH, Do you know why happen that.
msg229562 - (view) Author: Arfrever Frehtes Taifersar Arahesis (Arfrever) * (Python triager) Date: 2014-10-16 21:55
Have you received "configure: error: python3.4 interpreter not found" error before your changes?
msg396337 - (view) Author: Irit Katriel (iritkatriel) * (Python committer) Date: 2021-06-22 14:00
There has been no followup in over 6 years, so I am closing. If you are still having this problem with a current python version, please create a new issue.
History
Date User Action Args
2021-06-22 14:00:15iritkatrielsetstatus: open -> closed

nosy: + iritkatriel
messages: + msg396337

resolution: not a bug
stage: resolved
2016-03-02 00:27:35Alex.Willmersetnosy: + Alex.Willmer
2014-10-16 21:55:27Arfreversetmessages: + msg229562
2014-10-16 21:53:03bill9889setmessages: + msg229561
2014-10-16 21:44:55ned.deilysetmessages: + msg229559
2014-10-16 21:37:03bill9889setmessages: + msg229558
2014-10-16 21:30:16Arfreversetmessages: + msg229557
2014-10-16 21:29:33ned.deilysetnosy: + ned.deily
messages: + msg229556
2014-10-16 21:28:11bill9889setmessages: + msg229555
2014-10-16 21:21:41Arfreversetnosy: + Arfrever
messages: + msg229554
2014-10-16 21:12:03ned.deilysetnosy: + doko
2014-10-16 21:09:55bill9889create