This issue tracker has been migrated to GitHub, and is currently read-only.
For more information, see the GitHub FAQs in the Python's Developer Guide.

Title: Install failure of 2.6a1 on Windows XP without VS8 installed
Type: behavior Stage:
Components: Installation Versions: Python 2.6
Status: closed Resolution: fixed
Dependencies: Superseder:
Assigned To: Nosy List: christian.heimes, jkleckner, loewis, michaelurman
Priority: critical Keywords:

Created on 2008-03-07 23:33 by jkleckner, last changed 2022-04-11 14:56 by admin. This issue is now closed.

File name Uploaded Description Edit jkleckner, 2008-03-07 23:33 Zip compressed debug log file
Messages (8)
msg63371 - (view) Author: Jim Kleckner (jkleckner) Date: 2008-03-07 23:33
When I install 2.6a1 onto a Windoze machine I get a dialog:
  There is a problem with this Windows Installer package.
  A program run as part of the setup did not finish as expected.
  Contact your support personnel or package vendor.

Note that it didn't have VS2008 or any other new code installed.
The problem appears related to Tkinter but that isn't clear.

When running the Python console, running
  import Tkinter

results in an error saying that _tkinter can't be loaded.
  DLL load failed.  The system can't find _tkinter.pyd

_tkinter.pyd and tcl84.dll and tk84.dll are in DLLs and
appear to have reasonable permissions.

I suspect something in the install failed to set something
in the registry.

This is on a current-patch XP
system and that I also tried python-2.6.13944.msi
from the buildbot just in case after uninstalling/reinstalling
with no difference.

Attached is a compressed log of the install.

is the problem?

Here is an excerpt from the log file:

Property(S): Privileged = 1
Property(S): DATABASE = C:\WINDOWS\Installer\5f5ad0.msi
Property(S): OriginalDatabase = C:\cygwin\tmp\python-2.6a1.msi
Property(S): UILevel = 5
Property(S): Preselected = 1
Property(S): CostingComplete = 1
Property(S): OutOfDiskSpace = 0
Property(S): OutOfNoRbDiskSpace = 0
Property(S): PrimaryVolumeSpaceAvailable = 0
Property(S): PrimaryVolumeSpaceRequired = 0
Property(S): PrimaryVolumeSpaceRemaining = 0
Property(S): SOURCEDIR = C:\cygwin\tmp\
Property(S): SourcedirProduct = {0BA82E1B-52FD-4E03-8610-A6C76238E8A8}
Property(S): ProductToBeRegistered = 1
MSI (s) (FC:D0) [16:38:30:939]: MainEngineThread is returning 1603
MSI (s) (FC:C0) [16:38:30:939]: Destroying RemoteAPI object.
MSI (s) (FC:54) [16:38:30:939]: Custom Action Manager thread ending.
MSI (c) (E0:54) [16:38:30:954]: Back from server. Return value: 1603
MSI (c) (E0:54) [16:38:30:954]: Decrementing counter to disable 
shutdown. If counter >= 0, shutdown will be denied.  Counter after 
decrement: -1
MSI (c) (E0:54) [16:38:30:954]: PROPERTY CHANGE: Deleting SECONDSEQUENCE 
property. Its current value is '1'.
Action ended 16:38:30: ExecuteAction. Return value 3.
MSI (c) (E0:54) [16:38:30:954]: Doing action: FatalError
Action 16:38:30: FatalError.
Action start 16:38:30: FatalError.
Action 16:38:30: FatalError. Dialog created
Action ended 16:38:32: FatalError. Return value 2.
Action ended 16:38:32: INSTALL. Return value 3.
MSI (c) (E0:54) [16:38:32:375]: Destroying RemoteAPI object.
MSI (c) (E0:2C) [16:38:32:375]: Custom Action Manager thread ending.
Property(C): X = C:\Python26\Tools\pynche\X\
Property(C): UpgradeCode = {65E6DE48-A358-434D-AA4F-4AF72DB4718F}
Property(C): ProductName = Python 2.6a1
Property(C): ProductCode = {0BA82E1B-52FD-4E03-8610-A6C76238E8A8}
Property(C): ProductVersion = 2.6.101
Property(C): Manufacturer = Python Software Foundation
msg63383 - (view) Author: Michael Urman (michaelurman) Date: 2008-03-08 04:54
The failure is signaled by the return code from the call to
MSI (s) (FC:D0) [16:38:27:394]: Note: 1: 1722 2: CompilePyc 3:
C:\Python26\python.exe 4: -Wi "C:\Python26\Lib\" -f -x
bad_coding|badsyntax|site-packages "C:\Python26\Lib" 

The install succeeds anyway because this is after InstallFinalize. That
makes this a wart that will likely fail similarly on Vista under UAC (if
not already handled by being conditioned out). This should probably be a
scheduled between InstallFiles and InstallFinalize with
msg63406 - (view) Author: Jim Kleckner (jkleckner) Date: 2008-03-08 18:42
I uninstalled and re-ran the install without the "compile all" selected.

The install didn't report errors.

 python -c "import test.testall"
results in a traceback with the message:
      import _socket
   ImportError: DLL load failed: The system could not find the file

What sorts of things should I probe into?
msg64256 - (view) Author: Christian Heimes (christian.heimes) * (Python committer) Date: 2008-03-21 18:39
We are still having trouble with msvcrt90.dll and SxS assemblies (side
by side assembly dlls). Chris suggested to modify the manifest of the
Python dlls (pyd) files to look for the private copy of msvcrt90.dll in
the parent directory ..\.
msg65275 - (view) Author: Jim Kleckner (jkleckner) Date: 2008-04-09 22:13
msg65277 - (view) Author: Jim Kleckner (jkleckner) Date: 2008-04-09 22:18
It appears that issue2563 may be a dependency.
msg65287 - (view) Author: Martin v. Löwis (loewis) * (Python committer) Date: 2008-04-10 06:02
> Ping.

Does the problem still exist in 2.6a2? It shouldn't.
msg65324 - (view) Author: Jim Kleckner (jkleckner) Date: 2008-04-10 21:34
I hadn't seen any comment here that I should try it again until your
question (that was why the ping).

I did try it again and my application worked.

Date User Action Args
2022-04-11 14:56:31adminsetgithub: 46509
2008-04-10 22:00:45loewissetstatus: open -> closed
resolution: fixed
2008-04-10 21:34:57jklecknersetmessages: + msg65324
2008-04-10 06:02:45loewissetmessages: + msg65287
2008-04-09 22:18:46jklecknersetmessages: + msg65277
2008-04-09 22:13:28jklecknersetmessages: + msg65275
2008-03-21 18:39:31christian.heimessetpriority: critical
nosy: + loewis, christian.heimes
messages: + msg64256
2008-03-08 18:42:21jklecknersetmessages: + msg63406
2008-03-08 04:54:32michaelurmansetnosy: + michaelurman
messages: + msg63383
2008-03-07 23:33:46jklecknercreate