classification
Title: Installation flaky with multiple installers, old versions
Type: Stage:
Components: Distutils Versions:
process
Status: closed Resolution: accepted
Dependencies: Superseder:
Assigned To: akuchling Nosy List: akuchling, gward, mwh
Priority: normal Keywords:

Created on 2000-11-01 13:41 by gward, last changed 2002-02-01 18:30 by akuchling. This issue is now closed.

Files
File name Uploaded Description Edit
patch akuchling, 2002-02-01 15:08 Revised version of the patch
Messages (8)
msg2276 - (view) Author: Greg Ward (gward) (Python committer) Date: 2000-11-01 13:41
Installation tends to have problems when there are old installations present, especially when a different user is doing the new installation.

In particular, it appears that the chmod() done in 'copy_file()' (as a result of the "install" command attempting to preserve the mode of files from the build tree) fails, because you can't chmod() a file owned by somebody else.

Paul Dubois suggests that simply unlinking the target file before doing the copy should work.  I think he's right, but need to think about it and test it a bit first.
msg2277 - (view) Author: A.M. Kuchling (akuchling) * (Python committer) Date: 2001-09-20 18:41
Logged In: YES 
user_id=11375

I think unlinking first is the right thing to do, having 
just run into another problem that seems to be caused by 
this.  Installing *.so files to an NFS partition messed up 
other  people, I think because they had the *.so file 
loaded into memory and the kernel's VM got confused.  
(That's the theory, anyway.)

Bumping up the priority as a reminder to myself...

msg2278 - (view) Author: Michael Hudson (mwh) (Python committer) Date: 2002-01-23 16:07
Logged In: YES 
user_id=6656

I'll have a look at this, as I've already assigned some
installation related bugs to myself.
msg2279 - (view) Author: A.M. Kuchling (akuchling) * (Python committer) Date: 2002-01-31 20:35
Logged In: YES 
user_id=11375

This bit David Binger today, so I finally dug in and fixed 
it.  Patch attached for a sanity-check.
(2.2 bugfix candidate)
msg2280 - (view) Author: Michael Hudson (mwh) (Python committer) Date: 2002-02-01 10:26
Logged In: YES 
user_id=6656

Um, may be being dense, but os.unlink raises os.error if you
try to unlink a file that doesn't exist... so won't this
blow up in a first-time install for instance?
msg2281 - (view) Author: A.M. Kuchling (akuchling) * (Python committer) Date: 2002-02-01 15:08
Logged In: YES 
user_id=11375

Oops!  Shows I only tried it with a repeated install...  New
patch uploaded,  which only unlinks if os.path.exists(dst).
msg2282 - (view) Author: Michael Hudson (mwh) (Python committer) Date: 2002-02-01 15:16
Logged In: YES 
user_id=6656

That looks better.  Check it in?
msg2283 - (view) Author: A.M. Kuchling (akuchling) * (Python committer) Date: 2002-02-01 18:30
Logged In: YES 
user_id=11375

Checked in as rev. 1.12 of file_util.py.
History
Date User Action Args
2000-11-01 13:41:14gwardcreate