classification
Title: test_socket is flakey
Type: behavior Stage:
Components: Tests Versions: Python 3.0
process
Status: closed Resolution: works for me
Dependencies: Superseder:
Assigned To: Nosy List: gvanrossum, motteneder
Priority: normal Keywords: easy

Created on 2008-02-22 17:03 by gvanrossum, last changed 2008-02-25 17:24 by gvanrossum. This issue is now closed.

Messages (3)
msg62693 - (view) Author: Guido van Rossum (gvanrossum) * (Python committer) Date: 2008-02-22 17:03
I find that test_socket fails regularly (but not always) when run via
"regrtest.py -uall". The message is always "socket is not connected" but
it's unclear from which test it comes -- all I know is that it comes
from tearDown() on line 123.

(This may be a problem with 2.6 as well -- or not.)
msg62977 - (view) Author: Michael Otteneder (motteneder) Date: 2008-02-25 11:15
I'm not able to reproduce this with latest svn on OS X 10.5.2.
test_socket never fails.
msg62987 - (view) Author: Guido van Rossum (gvanrossum) * (Python committer) Date: 2008-02-25 17:24
It seems to work now for me too. I'll keep an eye out though.
History
Date User Action Args
2008-02-25 17:24:02gvanrossumsetstatus: open -> closed
resolution: works for me
messages: + msg62987
2008-02-25 11:15:33mottenedersetnosy: + motteneder
messages: + msg62977
2008-02-22 17:03:01gvanrossumcreate