classification
Title: Curses bug report for Python 2.7 and Python 3.2
Type: Stage: resolved
Components: Versions:
process
Status: closed Resolution: out of date
Dependencies: Superseder:
Assigned To: Nosy List: eclectic9509, zach.ware
Priority: normal Keywords:

Created on 2014-05-30 20:02 by eclectic9509, last changed 2020-04-27 01:29 by zach.ware. This issue is now closed.

Messages (2)
msg219425 - (view) Author: Richard s. Gordon (eclectic9509) Date: 2014-05-30 20:02
Curses bug report for Python 2.7 and Python 3.2

My Python code outputs text properly with xterm and xterm-16color. It does not work properly with xterm-88color and xterm-256color (after defining RGB color pallet) when run on Python-2.7 and Python-3.2 on Cygwin with Windows 7 Pro, Ubuntu Linux 12.04, Mac OS X 10.9.3 and PS-BSD 10.

For text output to xterm-88color and xterm-256color Python generates unique colors that are plagued by the wrong color and underline artifacts.

			xterm-16color			xterm-16color			xterm-88color						xterm-256color
			==========			==========			==========						===========
Region 1		cyan on black			cyan on black			cyan on olive with underlines			cyan on purple with underlines
Region 2		white on black			white on black			navy on black						white on orange
Region 3		yellow on black		yellow on black		magenta on black with underlines		navy on black with underlines

Some of my test platform terminals (such as iTerm2 on my iMac desktop system running Mac OSX Mavericks 10.9.3) default to xterm-256color and presumably already have Python 2.7.5 built for 256 color. I downloaded and built Python 3.2.2. 

My Python test code works properly with xterm and xterm-16color. Both display the wrong colors, some with underlines when run with xterm-88color and xterm-256color.

Any solutions or suggestions?

Richard S. Gordon
msg367340 - (view) Author: Zachary Ware (zach.ware) * (Python committer) Date: 2020-04-27 01:29
Hi Richard, sorry it too so long for anyone to respond to this issue!  It's been long enough that I'm going to assume that this has long since been fixed or worked around.  However, if you can still reproduce this with a modern version of Python (3.6-3.8), do please reopen the issue and attach some code that shows what's going on.
History
Date User Action Args
2020-04-27 01:29:42zach.waresetstatus: open -> closed

nosy: + zach.ware
messages: + msg367340

resolution: out of date
stage: resolved
2014-05-30 20:02:03eclectic9509create