This issue tracker has been migrated to GitHub, and is currently read-only.
For more information, see the GitHub FAQs in the Python's Developer Guide.

Title: IDLE won't open
Type: Stage: resolved
Components: IDLE, macOS Versions: Python 3.3
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: ronaldoussoren Nosy List: mélomane, ned.deily, r.david.murray, ronaldoussoren
Priority: normal Keywords:

Created on 2014-03-09 02:53 by mélomane, last changed 2022-04-11 14:57 by admin. This issue is now closed.

Messages (4)
msg212951 - (view) Author: (mélomane) Date: 2014-03-09 03:05
First time using Python on my personal computer. Updated the mac version to 3.3. Then installed ActiveTcl, then tried deleting and installing I tried opening IDLE from the applications folder, then from terminal. After that failed to work, I browsed the forms and tried what another user suggested to see if I had write permission to my home directory. 

Charlottes-MacBook-Pro:~ Charlotte$ /usr/local/bin/idle3.3

 Warning: unable to create user config directory
 Check path and permissions.

Charlottes-MacBook-Pro:~ Charlotte$ cd ~
Charlottes-MacBook-Pro:~ Charlotte$ ls -lde ~
drwxr-xr-x  23 501  staff  782  8 Mar 22:49 /Users/Charlotte
Charlottes-MacBook-Pro:~ Charlotte$ chmod u+w ~
Charlottes-MacBook-Pro:~ Charlotte$ mkdir ~/.idlerc
mkdir: /Users/Charlotte/.idlerc: Permission denied

Please help. :)
msg212952 - (view) Author: R. David Murray (r.david.murray) * (Python committer) Date: 2014-03-09 04:32
This isn't really a python question, it's a mac question.  Unless there is something the mac installer should be doing to detect this situation..but...are you running the python that comes with the OS, or did you install it yourself?  Because if it is the former, there probably isn't much we can do that we haven't already done.
msg212954 - (view) Author: Ned Deily (ned.deily) * (Python committer) Date: 2014-03-09 04:52
The fact that "ls" shows a UID of 501 instead of your user name "Charlotte" strongly suggests you have an inconstantly defined user account.  Suggest you try cresting a new "Administrator" user via "System Preferences" -> "User & Groups" and try logging into that user and see if IDLE works there.  If that works, you may need some help trying to fix up your existing account.  You may be able to get some useful information with the dscl command:

dscl . -read /Users/Charlotte

Good luck!
msg212955 - (view) Author: Ned Deily (ned.deily) * (Python committer) Date: 2014-03-09 04:55
er, "inconstantly" -> "inconsistently"
Date User Action Args
2022-04-11 14:57:59adminsetgithub: 65072
2014-03-09 04:55:30ned.deilysetmessages: + msg212955
2014-03-09 04:53:06ned.deilysetmessages: - msg212953
2014-03-09 04:52:50ned.deilysetmessages: + msg212954
2014-03-09 04:50:14ned.deilysetstatus: open -> closed

nosy: + ned.deily
messages: + msg212953

resolution: not a bug
stage: resolved
2014-03-09 04:32:54r.david.murraysetnosy: + r.david.murray, ronaldoussoren
messages: + msg212952

assignee: ronaldoussoren
components: + macOS
2014-03-09 03:05:34mélomanesetmessages: + msg212951
components: + IDLE
title: ID -> IDLE won't open
2014-03-09 02:53:07mélomanecreate