classification
Title: Make sure exec_module() implementations are documented
Type: Stage: needs patch
Components: Documentation Versions: Python 3.4
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: brett.cannon Nosy List: brett.cannon, eric.snow, ncoghlan, r.david.murray
Priority: low Keywords:

Created on 2014-02-26 23:48 by brett.cannon, last changed 2014-02-27 16:32 by brett.cannon. This issue is now closed.

Messages (3)
msg212330 - (view) Author: Brett Cannon (brett.cannon) * (Python committer) Date: 2014-02-26 23:48
E.g. importlib.abc.InspectLoader() has load_module() deprecated by no equivalent exec_module() documented. Make sure that no other exec_module() instances have been added but undocumented.
msg212335 - (view) Author: R. David Murray (r.david.murray) * (Python committer) Date: 2014-02-27 04:40
It doesn't?  I checked all the links that I made in the whatsnew entry when I made it, and importlib.abc.InspectLoader.exec_module takes me to an exec_module method entry under InspectLoader.
msg212364 - (view) Author: Brett Cannon (brett.cannon) * (Python committer) Date: 2014-02-27 16:32
Somehow managed to glance right over it. Guess I was more frazzled than I thought last night.
History
Date User Action Args
2014-02-27 16:32:01brett.cannonsetstatus: open -> closed
resolution: not a bug
messages: + msg212364
2014-02-27 04:40:07r.david.murraysetnosy: + r.david.murray
messages: + msg212335
2014-02-26 23:48:26brett.cannoncreate